Members via FB
  • Content count

  • Joined

  • Last visited

About ChrisF94

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  • Interests
    Car Modification
    Computers & Electronics
  1. If runs fine when it's warm, It idles at 1500 when I first start it, Then goes down as it warms up.
  2. I changed the ht leads and my battery is
  3. I've had a brand new CAT fitted and a coil pack but still the same issue.
  4. Hi, My MK1 focus takes about 5 seconds to start, I've Put new Ignition leads in, New spark plugs & Coil pack I don't know what it could be. I Changed the battery about 3 months ago. Sometimes when I have my lights on they go dim for a second when I'm driving. Thanks for any help.
  5. Okay, Thanks for your help.
  6. Forgot to mention I need a new clutch, Do you know what would be causing the smoke under the bonnet ?
  7. Hello everyone, I have a problem with my Ford Focus MK1 2002 1.6 Petrol. When I'm in gear 3 or above and put my foot down I get really high revs and no go, It sorts itself out after about 5 - 10 seconds. When I have the bonnet Up and I rev the car I can see white smoke coming from the back of the engine, And the exhaust makes a popping noise too. I also have a clogged CAT, Needs a new clutch, Will that be causing any of that ? Sometimes when I go round a corner I can hear a screeching noise from the left front wheel. Thanks for any help. Regards, Chris.
  8. Welcome to the Ford forums ChrisF94 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!