Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About mitsi

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  • Interests
    Road Trips
    Health & Beauty
  1. Thanks, ive got a new fuel pump now just got to get it fitted
  2. Ive been told its either the inertia switch or the fuel pump, ive found the inertia switch, is the button supposed to be down or up?
  3. nno it will fire up if I use easy start on it, but it wont rev, have checked accelerater cable thats fine.
  4. No old battery was shot, ive replaced this with a new one, am getting more new spark plugs tomorrow as my brotger says two arent sparking as well as the others, whereabouts is tge idle control valve?
  5. fuel filter has now been changed as well, still wouldnt start,
  6. how would I find out if its this?ive got a fuel filter just got to get my brother to change it for me.
  7. Oh and thanks for any help in advance.
  8. Hi, I have a problem getting my ka to start, its been sat there for a year whilst ive been kearning to drive, ive had a new battery, oil and filters changed, spark plugs are good, getting a good spark, its got fresh fuel in, ive just used easy start and got it started but it wont rev up very much and themn just cuts out. Any ideas on what the problem could be.
  9. Welcome to the Ford forums mitsi :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!