dr1v3r

Budding Enthusiast
  • Content count

    10
  • Joined

  • Last visited

About dr1v3r

  • Rank
    Member

Contact Methods

  • First Name
    mick

Profile Information

  • Ford Model
    MK3 estate
  • Ford Year
    2005
  • UK/Ireland Location
    Durham
  • Annual Mileage
    10,001 to 15,000
  • Interests
    General Automotive
    Motorsport & Racing
    Car Modification
    Travel
    Computers & Electronics
    Sports & Leisure
  1. Hi guys n possibly gals I am hoping that someone maybe able to help. I am in need of an actuator blend cable for my heater switches. The one I need is the large grey ended one part number 98AB-11503-AH I believe as numbers a bit faded I hope someone may have one of these laid around they might part with. Thanks Mick
  2. Or does anyone happen to know the part number of the blend cable that goes to the middle (face/window etc) switch please? Thanks Mick
  3. Hi gmx thanks for the reply and apologese for late response. Your right I finally got to tcheck it out andit does seem to be cable issue. Links in the cable aswell so looks like a new one. So I have to buy the whole unit or am I able to get each one separate? If can get separate what am I asking/looking for if it's the centre/direction switch (face/window etc) that does not work? Thanks again Mick
  4. Hi guy Ihave a focus estate mk1 ( I believe) Y reg. Anyway the heater control switch has stopped allowing us to change to windscreen, feet etc. Is anyone able to tell me if the controls from a focus hatch n saloon Will work? Thanks Mick
  5. My bad guys i didn't faster pipe back onto bottom of egr valve. Now it seams like more of a roaring noise at about 2000 revs
  6. Hi guys sorry if this has been posted already. I did look but couldn't see anything. Anyway my car has been running not very well at approx 2000 rpm in every gear. It seams to be what I would describe as a vibration from the front end. So I have changed diesel filter yesterday and saw a slight improvement and also cleaned egr and blanked it off today. When I jumped in car there are no warning lights of any kind and it seamed to go well untill I increased revs then power went and it feels like as if it is running in limp mode. I hope someone can assist. 05 115 mondeo estate diesel thanks mick
  7. Yea I checked levels. Well I believe it looks like a new clutch so flywheel aswell. Been quoted 485 all in so think I might just trying to make myself look cleverer than I am and go cry to a garage haha. Thanks guys appreciate the help.... Mick Sent from my GT-I9195 using Ford OC mobile app
  8. is that one in with clutch/gear box or the one near the pedal?
  9. hi guys new ere so if I am in wrong section I apologise. anyway my car has been driving fine, well I know I do need to do the flywheel but still been running ok, then today out of the blue the clutch pedal went extremely hard to press, and I know I probs made it worse but the resivoir was quite low so I bled the clutch incase was any air pockets. at that point I noticed the pedal dropped to the floor and only popped back to normal position when I lifted it myself. now I have done that the pedal is still hard to push but I can not sit in idle and change gears no problem and the car will not move at all. I checked for a spring at back of pedal and there is not one, now of reading posts off net it seams to be that some do have a spring and some don't, mine seams to be one without. I have sprayed the back of the pedal to see if it would free it in anyway and that has not worked either. I am hoping that someone maybe able to assist somehow please. thanks mick btw I am not mechanic I do tinker but usually engine wise it tends to be a local rip off also its an 05 estate and I think its a mk3 but please correct me if I am wrong thanks
  10. Welcome to the Ford forums dr1v3r :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/