Comfortably Numb

Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Comfortably Numb

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    Mondeo ST Tdci
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    15,001 to 20,000
  • Interests
    Motorsport & Racing
    Food & Drink
    Sports & Leisure
  1. Thanks for taking the time to respond Lenny, appreciated :)
  2. What are the benefits of the green cotton filter Lenny, i used to put an Sti paper filter in my Subaru's and there was a definite performance improvement. Never really considered any inductions upgrades on a diesel, I've never been one for dump valves and the like just subtle natural upgrades such as air filter and exhaust systems
  3. Couldn't agree more. Loving the car, hence I wanted to get it fixed up rather than moving on to something else. Great value for money, no creaks or groans a good solid car with all the toys drives great, plenty of leg room front and rear, the body kit is subtle but makes all the difference and now the engine is back up to optimum running the daily 90 mile motorway round trip is a real pleasure.
  4. Yes "now the car is running properly" :D
  5. If it helps anyone that is suffering My tdci had a new set of injectors in Dec then two were replaced a month ago with a new fuel filter and still the problem persisted. Gave it to my neighbour a Ford master tech, he checked the fuel filter and it was clogged with swarf, he dropped the fuel tank and again swarf. Replaced the two knackered injectors, cleaned out all of the fuel lines as well as the fuel tank removed all of the swarf now the car is running properly. It appears the two previous injector changes were carried out without the fuel system being flushed and cleaned hence the problem will continue to come back !!! The swarf was the issue all along, In his words, never let the diesel run low as the swarf comes from the high preassure pump using the diesel as a lubricant if there isn't enough diesel the pumps plates will rub together causing minute amounts of swarf to build up eventually clogging up the injectors.
  6. Hi I'm new to the forum, and wondered if your combined knowledge can offer me some advice. I have read many threads on the subject (of the symtoms) as it is a regular issue for this car or so I believe. So if you have the patience I'd like to share my story :) A few weeks ago I bought a 2006 ST Tdci, FSH, 63000 on the clock, lovely condition in and out always maintained on time, any issues dealt with and all receipts for any work carried out. So happy with my purchase off I drove around the M25 homeward bound, entered some roadworks with a 50 mph restriction, during exiting the restriction I accelerated away, as I was still finding my feet so to speak I didn't floor it, a small jolt was felt and the glow plug light came on followed by the engine and I was in limp home mode. Got her home and called the 2nd hand dealer who advised to drop it off at my local garage and have it checked out and he would cover any costs, apologising for any inconvenience etc etc. Dropped it off at a garage I use for servicing plus they'd done an excellent job rectifying an electrical fault on my wifes old Punto, so I have full confidence in these guys. They duly noted that errors were coming up and suggested that two injectors needed replacing plus the fuel filter, work carried out and paid for by the dealer and for a week the car was fine...... Then the issue came back, although this time the engine warning light wasn't coming on in tandem, and hasn't come on at all. In the main it's going into limp home mode and on some occasions it would cut out entirely, which is a little nerve racking to say the least especially in rush hour in lane 2 of the M3, trying to get across to the hard should before grinding to a halt. First port of call was to take it back to the garage and they plugged it in and again error codes were coming up and they suggested the two injectors they didn't replace may have failed or the High pressure pump is playing up and I'd need to speak with the dealer because there would be more cost involved, so I gave him a ring to discuss, he says take it back to your garage they diagnosed it and if they diagnosed it incorrectly they should rectify it as he's already shelled out £550 for the work done. Now I don't want to be going back to the garage and saying " I think you've misdiagnosed it" as I'm sure this will offend and wont get me anywhere, because technically they did "fix" it for a week. I have been through all of the paperwork and found that in December 2013 the previous owner had 4 new injectors and a high pressure pump fitted and in October 2013 he'd had a new EGR valve fitted. All common issues in relation to this fault and from what I've read ion here and various other forums are the main reasons for the glow plug light flasing and the car going into limp home mode or cutting out. It must be noted that at the time when they replaced the fuel filter and two injectors they weren't aware of the work that had been carried out in Dec 2013 and to my shame neither was I until I studied the documentation more carefully. So it got me thinking surely my guys wouldn't have had to replace two injectors so soon after having 4 new ones fitted 3000 miles ago. Would something cause the injectors to fail so soon ?? I intend to return to my guys with this information and hope we can discuss how to move forward and they can come up with a correct diagnosis. I also wonder if the work carried out for the previous owner in December 2013 is still under warranty if any of those parts have failed, any idea's on this front ? I want to keep the car but this whole issue is becoming a minefield and I feel like I'm stuck between two parties who are now saying it's down to the other party and no doubt it will fall on me to pay out for it to be fixed :( I understand it's been a rambling post but if anyone can offer any advice on where I stand on getting it fixed based on the work the previous owner has had done in recent months and where I'm at now it with the dealer and my garage it would be appreciated as I'm not in a position to shell out large sums of money. Likewise if anyone recognises the symptoms from what I've stated above and can offer advice on what the potential root cause could be I would be very very grateful. Sadly I have no codes I can give you. Thanks for reading Dave
  7. Just wanted to say hi After a rather long time away from the Blue Oval, I am a Ford owner again. Last had an Orion Ghia i and sold it for a 320i back in 1994, so after many years of BMW and Subaru ownership and a brief 2 year spell living in Australia I came home and had to buy a sensible "family" car so ended up with a Volvo V50 for 4 years. Ssadly this was written off a couple of months ago and I decided on a Mondeo ST Tdci, something I'd looked at 4 years ago but couldn't find a nice one, hence the Volvio. Sadly however it hasn't been the best start as you'll discover in subsequent posts but I intend to persevere with it as I'm really enjoying the Mondeo. Cheers CN
  8. Welcome to the Ford forums Comfortably Numb :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!