Sharas

Members via FB
  • Content count

    3
  • Joined

  • Last visited

About Sharas

  • Rank
    Newbie

Contact Methods

  • First Name
    Sarunas

Profile Information

  • Ford Model
    Ford Mondeo tddi ghia X
  • Ford Year
    2002
  • UK/Ireland Location
    Norfolk
  • Annual Mileage
    0 to 5000
  • Interests
    General Automotive
    Car Modification
    Computers & Electronics
  1. Sounds like theres shortage in a circuit. Any advise on where should I start to look for or how do I check if there is a shortage for shure? Thanks
  2. I double checked part numbers for my model and its a right one
  3. Hi today my alternator caught on fire. I had some issues before, when driving in hot day London traffic felt burning smell. After inspecting noticed wires in alternator had plastic melted. Next day I went to a garage and they tested my alternators voltage which was to high. Engineer told me that alternator is faulty and will pack up soon. Which it did today (after 8 months). I did get a new alternator and fitted today, but when I tested it had 16V on idle and 15.7 with lights and con on. My mondeo have a heated seats, factory fitted xenon lights, and so on. After running for about 3mins it started smelling burn again and alternator is to hot to touch. What could be a reasons of that? Please help
  4. Welcome to the Ford forums Sharas :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/