justinparry

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

  1. Yeah runs fine just sounds awful when idle. Going through a lot of fuel also and was thinking this may be why. Im going to try new HT leads but doubt that will change much. Sent from my iPhone using Ford OC
  2. I have a 2009 ford focus zetec 1.6.. When i got it, it sounded fine, then it started to sound a bit tapperty. So i serviced it (new plugs. Oil/oil filter. Air filter) and it was still tapperty? I serviced it again today and no change! The engine splutters now and again aswell and it is idling at 900 and sounds like a diesel with the bonnet open! Is this common? And how do i fix it any ideas? Sent from my iPhone using Ford OC
  3. 900 not 9000 Sent from my iPhone using Ford OC
  4. I have a 2009 ford focus zetec 1.6.. When i got it, it sounded fine, then it started to sound a bit tapperty. So i serviced it (new plugs. Oil/oil filter. Air filter) and it was still tapperty? I serviced it again today and no change! The engine splutters now and again aswell and it is idling at 9000 and sounds like a diesel with the bonnet open! Is this common? And how do i fix it any ideas? Sent from my iPhone using Ford OC
  5. Welcome to the Ford forums justinparry :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/