AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


The Artful Dodger

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About The Artful Dodger

  • Rank
    Newbie

Contact Methods

  • First Name Paul

Profile Information

  • Ford Model focus
  • Ford Year 2005
  • UK/Ireland Location Gloucestershire
  • Annual Mileage 0 to 5000
  1. Help Please

    Thanks Ade, I have ordered a new fuse box & spoken to a local auto electrician & the key is coded to the module inside the fuse box. Total repair will cost £400.
  2. Help Please

    Hi Everyone, I'm new to this site & need your help, I am a plant fitter by trade & know my way around cars ( a bit ) I have a 55 plate focus that's doing very odd things, 1st thing is when the cars cold it starts OK but the headlights flash & when its running for the first 10 seconds the dash gauges flicker, 2nd thing is when its hot, when i try to start it says engine systems fault & i can hear a relay chattering in the fuse box on the passengers side, but there's no fault codes in the error log, & its a sod to start, I have had the fuse box out & took the lid off & there's been water in there & showing signs of corrosion on various fuse holders & pins, Has anybody had this or heard of this & if i change the fuse box do i need to get the ignition key recoded to the new fuse box, Cheers Paul