AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


ecorgb

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About ecorgb

  • Rank
    Newbie

Contact Methods

  • First Name Eco

Profile Information

  • Gender* Male
  • Ford Model Fiesta Zetec Ecoboost 1.0L
  • Ford Year 2013
  • UK/Ireland Location Kent
  • Annual Mileage 5001 to 10,000
  1. Just got a oneplus one mobile but I can't get the sms feature to work with my 2013 fiesta, it worked fine with my moto g phone but not this oneplus one. Anyone know what the problem could be?
  2. Went Into Ford

    I took my fiesta 2013 into ford due to a wind/whistle sound inside the cabin when window open, if flow control is set to flow to floor then no sound but aim flow to window and you get a high pitch whistle. Ford had car all day and come back with no problem found and 2 others models of this age/mileage had the same sound???? Can't believe no one else has heard this and ford not sorting the problem. Also whilst at Ford I said there was a noise from engine bay I never noticed when vehicle was purchased, the guy went straight to the part in the picture, put he's hand over the part and the sound went away, he said this is the way they are built and every model will have a different sound and went on to say some models have a rubber cover over this part to dead the sound. So not much help overall from Ford on my problems. What is the part called in this pic because I forgot what he called it?
  3. Your Fiesta

    Little Eco boost I have just purchased.
  4. Strange Whistle Sound??

    Only owned this 2013 5dr fiesta zetec 1.0l ecoboost for just over a week now and after taking it on a motorway noticed an annoying sound. When doing 60mph+ you get a horrid whistle/wind sound with window open on either side of car, it goes away with window/s shut. Tried closing vents, unscrewed aerial but it is still there, then I changed the position of where air flows with the control and the sound seems to go away when flow direction is set to flooring area, but set anywhere else the sound is back, also goes away when you turn on heater motor position to 1 or above? but why when a window is open? Anyone else have this or heard of this problem? Emailed Ford where I purchased the car from and now awaiting a reply.