• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


xxvv

New Member
  • Content count

    1
  • Joined

  • Last visited

About xxvv

  • Rank
    Newbie

Profile Information

  • Ford Model
    Fiesta mk5 Zetec-S
  1. Basically my y reg zetec-s had a little trouble starting up in the mornings, for a few seconds it would almost stall and eventually idle. Cleaning up the engine bay, checking levels noticed a strange orange/brown build up around the spark plug leads, after taking the leads off realised the spark plugs were pretty much completely submerged in brown water. Drained all the water cleaned the leads and the car started fine with no stalling or anything. Took the car to a petrol station near by, car runs fine up until a certain point (approx 1 mile) where all power is lost and i have to rev very high in 1st/2nd to keep to running and get it back home (the car then wont start for a few hours). Tried the same journey twice and again at approx 1 mile it does exactly the same thing (just appears to be no power above 2nd gear). The car is going into the garage in the morning to see what the problem is, though am i bit clueless and would like to know if anybody has had anything similar or know what might be up (and also so i don't get completely screwed by the garage). - this has only happened after draining the water from the spark plugs. Any advice would be much appreciated!