Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About JHANNAH0151

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  • Interests
    General Automotive
    Road Trips
    Food & Drink
    Computers & Electronics
  1. I've check the pipe over again this morning that was ok but one found one on another pipe could that be causing the hising noise Sent from my iPhone using Ford OC
  2. Hi I took the intercooler pipe off checked it all over an there was no splits I've fitted it back on an the humming noise is still there at 2500 revs an above but there is no lose of power has anyone got anymore advice Sent from my iPhone using Ford OC
  3. ok am quiet handy one the tools for when am back in the TA on Monday ill ask the lands if I can get it on the ramps to look under it sorry to snd like an idiot asking this but if there is an split in the pipe would that be kicking the powertrain mode off
  4. hi can someone help am i got a car a few days ago im having the same issue with my turbo but there no lose of power just the noise plus from time to time I get a power train malfunction light on but if I turn the car off then back on it doesn't come on and also when i turn the lights on in the car the airbag light comes on gos off for around 7 seconds then comes back on the no signs from it showing any fault codes when i plug an odb2 scanner it comes back ok
  5. Welcome to the Ford forums JHANNAH0151 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!