Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


kiak

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About kiak

  • Rank
    Newbie

Contact Methods

  • First Name Ell

Profile Information

  • Ford Model Fiesta Titanium X
  • Ford Year 2014
  • UK/Ireland Location Yorkshire
  • Annual Mileage 0 to 5000
  1. I eventually went around the area reseating all the connectors I could see and it started working again. Must have been one :)
  2. Hi All, This is my first post, I'm hoping you could give me a bit of advice. I've bought a new fiesta (titanium x) 3 months ago. A couple of weeks later I fitted a brodit phone holder/charger, one of the hard wired installed ones. I did this by feeding the wires behind the trim between the feet of the driver and passenger - through to the passenger footwell and up into the fuse box area. I wired it in using a piggyback adapter (this sort of thing)- I piggybacked off the passenger heated seat fuse position and grounded off one of the chassis bolts at the top. . This worked perfectly for a month or so until a few days ago. The right stalk on the steering wheel (the one controlling the wipers and washers) seems to have stopped working. In addition the rear parking sensor has stopped both beeping and showing the visual indicators on the reversing camera screen - although the camera does still work. The washers and wipers are on different fuses so I doubt it would be a fuse gone- as the rear wiper has also stopped working I assume the entire stalk is dead. I was quite careful when I installed the phone holder but I'm wondering if I could have knocked a wiring connector loose back there. Does anyone know if these items share a connector? If there is a connector I can re-seat I'd rather just do that but I don't want to just mess around back there and risk making it worse in my ignorance. I expect if I take it to the dealer they will blame me for the phone holder install. Of course I could remove this item fairly easily as it is all removable. Anybody get any ideas? Thanks in advance.
  3. Welcome to the Ford forums kiak :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/