AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Stuzo237

Budding Enthusiast
  • Content count

    21
  • Joined

  • Last visited

About Stuzo237

  • Rank
    Member

Contact Methods

  • First Name Stuart

Profile Information

  • Gender* Male
  • Ford Model Ford fiesta zetec freestyle
  • Ford Year 2002
  • UK/Ireland Location Angus
  • Annual Mileage 5001 to 10,000
  1. Engine Light On/ Eggy Smell

    Ah I see well looks like I'm buying that spark plug feeler and get them all the right size and hopefully it works better I'll keep you posted how I get on with this thanks for the comments , tips, advice and help ,well appreciated .
  2. Engine Light On/ Eggy Smell

    I thought when these ngk spark plugs and coz I gave the supplier my reg they would jus go in as they are, so I have to buy feeler blades ? And how will I know what I set the spark plugs at for Ford Fiesta zetec 1.2 16v 2002 I mean is there a number I have to set them at ? New to all this sorry learning
  3. Engine Light On/ Eggy Smell

    What do you make of this people the eggy smell has gone totally and when I replaced the 4 old spark plugs to the 4 new ngk spark plugs it didn't do any difference so here's what happened I took the new spark plugs out and tapped them a bit lower the 4 of them all same in size , put them back in and my car was back to normal except the engine light was still on that's the only thing so went for a drive and all was good then come back sat idle for 5 mins just to make sure the juddering and spitting noise from exhaust was all gone and boom it started up again so took spark plugs back out again tapped them some more put them back in and made it a lot worse more jittery and spitting noise from exhaust so last time I was doing this ,took the spark plugs back out opened them up just a tiny bit put them back in and now my car is back to normal and all is fine but for how long I mean will this come back or do you think all is well.
  4. Engine Light On/ Eggy Smell

    I'm going to get that checked going to take it to garage on Monday as the garage said it should be fine to drive about with what I have described to him but he said not to go really far jus incase.but going to avoid driving until I have too and that's to take it down on Monday
  5. Engine Light On/ Eggy Smell

    I should of said but there was a bracket broke at mid front of the car for the exhaust but had this fixed from garage a week ago, you don't think that has anything to do with it do you ,also when my car is going fast it seems fine and when I say fast I mean at 30 mph anything under that , the juddering starts like going to stall and rumbling vibrations
  6. Engine Light On/ Eggy Smell

    Well wat ever it is I don't have a clue got 4 new ngk spark plugs today and fitted them in and the car was still doing the same minus the smell so took spark plugs back out and tapped them abit lower all same size fitted them back and all was fine car was good no spitting from the exhaust no juddering And no smell only thing the engine light was still on, so took it for a drive for a bit and on way back home after driving around for 45 mins I sat at idle on my street and there it was back again exhaust spitting, juddering started to come back like the car was wanting to move its self , also at one point it was like my car was away to stall and shut down even though it wasn't in gear but there's a lot of rumbling vibration on gear stick and I feel it on my feet. I checked leads they all look good now I'm lost , any ideas would be appreciated also thanks for your comments guys
  7. Engine Light On/ Eggy Smell

    I just had my clutch replaced a week ago as my previous clutch went, so bought brand new clutch and had garage fit it
  8. Engine Light On/ Eggy Smell

    Thanks guys for your ideas ,help and quick response going to get new set of ngk plugs tomoz fit them and let you know how I got on, fingers crossed that it's only sparkys.
  9. Engine Light On/ Eggy Smell

    The Original ones when I bought the car are ngk and car was going great so 6 months ago I got service pack for car and I had got Bosch ones and when I put these in my car it was misfiring and smelt like a rotten egg so put back the ngk old ones back in and everything was ok and as 6 months went on I think it's time for new ngk spark plugs as the Bosch ones do not agree with my car somehow.
  10. Engine Light On/ Eggy Smell

    Hi and thanks for your reply so it would be a good idea to get spark plugs and see if that works and if not then it's the leads or coil. That's funny that I got a service pack about 6 months ago changed the oil filter and put new oil into the car unfortunelty the fuel filter wasn't the right size for my fiesta even though I gave the supplier my reg. and as for the spark plugs I put them all in and my car was misfiring along with the smell and really lose of power so I put the original sparks plugs back in and it was good as new so as I've had these orginal spark plugs for a very long time I think I'm needing new ones hence the reason for my car acting the way it is
  11. Hi everyone I am having a slight or maybe a major problem with my Ford Fiesta zetec 1.2 16v 2002 car. Here goes I was driving home and as I was going up a slight hill my car started to lose power and I knew at that point something is wrong so after making it over the slight hill my car started to smell like rotten eggs I looked at temp it was all ok but I did notice there was a orange engine light was blinking then as I was almost home the engine light was on solid and my car started to judder along with this smell, so I parked up near my street and checked the oil, water, even checked for the smell and couldn't smell anything only when I was in the car and it was coming from the air vents. So if anyone has any ideas what this could be please let me know many thanks stu
  12. Heater Problem !!!

    First off I'm new to this forum , I would like to say hi to everyone on here Well here goes it's about my ford fiesta freestyle zetec 2002 car, I have a heating issue problem I have took it to 2 garages and they can't fix it or even determine the problem so I'm about to get to the point and issue. This is how it all started, I had a water leak comming from my car and the leak started to get worse so had to take it to the garage and they said I needed a new thermostat and some sort of sealer so I said that's fine as I was wanting my car fixed then 2-3 hours after the garage having the car they phoned me back saying I also needed a new motor heater valve so the bill was going to be a it more originally so I then said ok , so paid the money which was £90 and had said everything was fixed leak , thermostat and motor heater valve. Took my car back home but just before I got home I stopped at a set off traffic lights and a big gust of hot air started comming through the vents even though the heater switch was on cold so I pulled over at the side of the road wondering should I drive or not I wasn't sure if it was safe so decided to drive home still hot air and the temp guage at normal halfway and didn't rise. Took it back to the garage many of times and still couldn't fix it. When to a different garage, I don't like changing garages but I think I was getting ripped off in a sense so went to another garage and explained all what has happened and only asked this garage to determine the problem with the heater blowing hot air I did not ask them to fix this so I was waiting for a phone call the day my car went in to get checked not fixed and they phoned up saying you can collect your car I said how much would this be and did you determine this fault , they said it's going to be £60 and it was the motor heater valve again even though I said to the garage I just wanted it checked not fixed and also I already told the garage that's the 3rd motor heater valve been installed are you sure it's fixed he replied yes it's blowing cold and hot air so I was just glad to hear this and didn't moan about them fixing it as this is what I wanted so went to pay the cash and took my car home picked up my misses and kids to go for a drive, so sat in the car outside my house with the car still but engine on and before the kids and misses came out to get in the car hot air started to blow again. Went back to the garage told them about this and said I've just paid you money for you to fix this problem and it has come back again hot air constantly he said bring in tomorrow I will get a sparky to look at it, sparky looked at it and said I needed a heater control panel that is what is causing the problem so he phoned up and said I need to get this part then it will be fixed plus he said I will fit it for free I get the part , so got the original control heater part they fitted it and said it's working now come collect your car so got my car back drove for a while to see if all was well and the heaters where blowing cold air I'm like yes it's fixed as it was really hot as well but I never thought to turn the heater switch to hot, it wasn't until my partner said does it go not as well I had said I haven't even checked, so now to test this and turned the heater switch too hot and no hot air even though I was driving about for an hour. I stopped the car and popped the hood and noticed a wire dangling from under the hood at bottom of windscreen and this wire was ment to be connected to the motor heater valve so I connected it still nothing Drove about to see no hot air, hmmmm so phoned the garage to explain that the person working on my car left this wire hanging out he replied oh he must of forgot to put it back in and said did it work when you put the wire back in I had said no, he then asked me to bring it back in for another check later that day, I had another check under the hood and this is what I seen there was a U bend pipe like on the heater valve and my original pipes where tucked under the U bend pipe, so when I went back to the garage and confronted them regarding this, the garage replied yes I knew there was a U bend on there I asked why ? And why did you not tell me of this he said just when You left the garage he forgot to tell me off this his son had done this but he didn't tell the other garage person. I asked why did you or your son do this , I asked for this heater control panel you said I needed which by the way I payed £32, I said I asked for the heater to be fixed and back to normal I have done everything you have asked of me he then said bring it in again to get it check by the sparky again, it's becoming a joke now even tho he isn't charging me for this sparky, getting the control panel fitted he said I'm getting all this done for free but in reality I'm not as the way I see it I payed £60 for maybe something I didn't need and a heater control panel £32 so £92 I have payed to get my heaters fixed and they Aren't, it's blowing constant cold air even though they took the U bend pipe off and reconnected the original pipes and with the wire connected nothings working. Anyway sorry for the big long story I was just wondering if anyone has any other ideas what this might be, thermostat checked , motor heater valve checked , I have water in my tank checked, there's no leaking, heater control panel replaced checked, I don't know what else this could be has anyone else got any thoughts or ideas on this or maybe you,ve had this very same problem and had this fixed would be appreciated many thanks stuart
  13. First off I'm new to this forum , I would like to say hi to everyone on here Well here goes it's about my ford fiesta freestyle zetec 2002 car, I have a heating issue problem I have took it to 2 garages and they can't fix it or even determine the problem so I'm about to get to the point and issue. This is how it all started, I had a water leak comming from my car and the leak started to get worse so had to take it to the garage and they said I needed a new thermostat and some sort of sealer so I said that's fine as I was wanting my car fixed then 2-3 hours after the garage having the car they phoned me back saying I also needed a new motor heater valve so the bill was going to be a it more originally so I then said ok , so paid the money which was £90 and had said everything was fixed leak , thermostat and motor heater valve. Took my car back home but just before I got home I stopped at a set off traffic lights and a big gust of hot air started comming through the vents even though the heater switch was on cold so I pulled over at the side of the road wondering should I drive or not I wasn't sure if it was safe so decided to drive home still hot air and the temp guage at normal halfway and didn't rise. Took it back to the garage many of times and still couldn't fix it. When to a different garage, I don't like changing garages but I think I was getting ripped off in a sense so went to another garage and explained all what has happened and only asked this garage to determine the problem with the heater blowing hot air I did not ask them to fix this so I was waiting for a phone call the day my car went in to get checked not fixed and they phoned up saying you can collect your car I said how much would this be and did you determine this fault , they said it's going to be £60 and it was the motor heater valve again even though I said to the garage I just wanted it checked not fixed and also I already told the garage that's the 3rd motor heater valve been installed are you sure it's fixed he replied yes it's blowing cold and hot air so I was just glad to hear this and didn't moan about them fixing it as this is what I wanted so went to pay the cash and took my car home picked up my misses and kids to go for a drive, so sat in the car outside my house with the car still but engine on and before the kids and misses came out to get in the car hot air started to blow again. Went back to the garage told them about this and said I've just paid you money for you to fix this problem and it has come back again hot air constantly he said bring in tomorrow I will get a sparky to look at it, sparky looked at it and said I needed a heater control panel that is what is causing the problem so he phoned up and said I need to get this part then it will be fixed plus he said I will fit it for free I get the part , so got the original control heater part they fitted it and said it's working now come collect your car so got my car back drove for a while to see if all was well and the heaters where blowing cold air I'm like yes it's fixed as it was really hot as well but I never thought to turn the heater switch to hot, it wasn't until my partner said does it go not as well I had said I haven't even checked, so now to test this and turned the heater switch too hot and no hot air even though I was driving about for an hour. I stopped the car and popped the hood and noticed a wire dangling from under the hood at bottom of windscreen and this wire was ment to be connected to the motor heater valve so I connected it still nothing Drove about to see no hot air, hmmmm so phoned the garage to explain that the person working on my car left this wire hanging out he replied oh he must of forgot to put it back in and said did it work when you put the wire back in I had said no, he then asked me to bring it back in for another check later that day, I had another check under the hood and this is what I seen there was a U bend pipe like on the heater valve and my original pipes where tucked under the U bend pipe, so when I went back to the garage and confronted them regarding this, the garage replied yes I knew there was a U bend on there I asked why ? And why did you not tell me of this he said just when You left the garage he forgot to tell me off this his son had done this but he didn't tell the other garage person. I asked why did you or your son do this , I asked for this heater control panel you said I needed which by the way I payed £32, I said I asked for the heater to be fixed and back to normal I have done everything you have asked of me he then said bring it in again to get it check by the sparky again, it's becoming a joke now even tho he isn't charging me for this sparky, getting the control panel fitted he said I'm getting all this done for free but in reality I'm not as the way I see it I payed £60 for maybe something I didn't need and a heater control panel £32 so £92 I have payed to get my heaters fixed and they Aren't, it's blowing constant cold air even though they took the U bend pipe off and reconnected the original pipes and with the wire connected nothings working. Anyway sorry for the big long story I was just wondering if anyone has any other ideas what this might be, thermostat checked , motor heater valve checked , I have water in my tank checked, there's no leaking, heater control panel replaced checked, I don't know what else this could be has anyone else got any thoughts or ideas on this or maybe you,ve had this very same problem and had this fixed would be appreciated many thanks stuart