Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


hairybiker25412

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About hairybiker25412

  • Rank
    Newbie

Contact Methods

  • First Name
    Ian

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta
  • Ford Year
    2007
  • UK/Ireland Location
    Aberdeenshire
  • Annual Mileage
    5001 to 10,000
  1. Yeah it's the right bulbs, I'll try more just to make sure they weren't duds but like I said the ones fitted just now and the ones that originally came off appear to be fine - filament still whole ect. I have checked the fuse and the connector at the bulbs with a multimeter and they are both giving readings, The high level middle brake light isn't LED so thats not the problem, I'll get a new set of bulbs but if they dont work I might try a new switch to see if that cures it? Cheers
  2. Hi, I am having a problem with the brake lights on my 2007 Fiesta, The 2 side brake lights aren't working but the midle high level one is working! I have changed both side bulbs but the that hasnt helped, the old ones that came out were fine too, I changed the fuse too but again that hasn't helped and the one that came out was also fine, I then checked the switch behind the brake pedal and it's still working the high level brake light but not the side ones Are the standard high level brake lights LED? If so would it have a different fuse? I know LED lights use a lower voltage than normal ones... The car is due MOT in a few weeks so any input would be appreciated :) Cheers
  3. Hi, I am having a problem with the brake lights on my 2007 Fiesta, The 2 side brake lights aren't working but the midle high level one is working! I have changed both side bulbs but the that hasnt helped, the old ones that came out were fine too, I changed the fuse too but again that hasn't helped and the one that came out was also fine, I then checked the switch behind the brake pedal and it's still working the high level brake light but not the side ones Are the standard high level brake lights LED? If so would it have a different fuse? I know LED lights use a lower voltage than normal ones... The car is due MOT in a few weeks so any input would be appreciated :) Cheers
  4. Hi

    Hi, My name is Ian, I have a MK6 Fiesta Zetec S (TDCI) and a 2008 Civic Type R. I'm looking for some advice on a problem I am having with the brake lights on my Fez... :( Cheers
  5. Welcome to the Ford forums hairybiker25412 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/