Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


hondacr250

Budding Enthusiast
  • Content count

    9
  • Joined

  • Last visited

About hondacr250

  • Rank
    Newbie

Profile Information

  • Ford Model
    03 plate st170
  1. hi i ran out of petrol last week in my st170 and eventhough i got it started and been driving it around and it seemed to be ok but then the engine management light came on with the code PO325 knock sensor 1 circuit (bank1 or single sensor) circuit malfunction. if any1 knows where i can find this part under my bonnet much appreciated if you could tell me. thanks
  2. hi wonder if any one can help? when im driving my st170 and i put my foot down it gets to just before 4000 rpm and it is being restricted by something it judders when it gets to this point and wont let me go past it? the car is not running at its full potential. :( i had a problem kind of like this before and it was my intake manifold runner control module which has now been replaced. someone has mentioned it could be the mass air flow sensor because i have added a uprated air filter? i have changed my coil pack and had new leads and new spark plugs. if any one can help me please
  3. hi i have a focus st170 and mine is doing the same as yours - changed alternator and light is still on. i have had a few people message me back with -a bad earth in the car? dodgy alternator and battery well mine is none of those. my car is in the garage at the moment to see if they can find the problem so ill let you know.
  4. hi i have a focus st170 and mine is doing the same as yours - changed alternator and light is still on. i have had a few people message me back with -a bad earth in the car? dodgy alternator and battery well mine is none of those. my car is in the garage at the moment to see if they can find the problem so ill let you know.
  5. i have had it all checked and the battery is charging. is the alternator connecting clip the one that is on the top of the alternator? a rac man told me it was called a smart charge but i have been to ford and they dont no wat im going on about, is this the same thing as your saying if so how do you fix the problem?? thanks
  6. yeah ive cleared the fault code and its now just the battery light staying on when the car is running, the lights are also all flickering when its running any more ideas?? thanks
  7. hiya thanks for getting back to me the engine management light is not on now ive had it reset, the battery light is still on though and when the car is running all my lights are pulsing (Flickering)? but its still charging the battery?
  8. i wonder if any1 can help? ive got a 03 plate mk1 ford focus st170 and recently the engine management light came on with code P1246- Alternator load input failed possible causes wiring or alternator. the battery light is staying on when i am running the car? i have changed the alternator, the battery is newly new and im not sure where to look? if any one can help me i need to get it sorted. thanks
  9. i wonder if any1 can help? ive got a 03 plate mk1 ford focus st170 and recently the engine management light came on with code P1246- Alternator load input failed possible causes wiring or alternator. the battery light is staying on when i am running the car? i have changed the alternator, the battery is newly new and im not sure where to look? if any one can help me i need to get it sorted. thanks