• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Irishman1127

Budding Enthusiast
  • Content count

    73
  • Joined

  • Last visited

About Irishman1127

  • Rank
    Settling In Well
  • Birthday August 14

Contact Methods

  • First Name
    George

Profile Information

  • Gender*
    Male
  • Ford Model
    Mk1 Focus
  • Ford Year
    2000
  • UK/Ireland Location
    Roscommon
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Car Restoration
    Car Modification
    Travel
    Road Trips
    Food & Drink
    Entertainment
    Computers & Electronics
    Arts & Crafts
    Literature
    Sports & Leisure
    Health & Beauty

Recent Profile Visitors

910 profile views
  1. Ford Focus Mk1 Common Problems Thread

    Id be looking at the coil pack and/or the camshaft positioning sensor. normally if its the coilpack it leads to poor running. The turning ouver but no firing sounds like a camshaft sensor to me
  2. Mk1 Focus

  3. Mk1 Focus

    I'll get right on that buddy!
  4. Mk1 Focus

  5. Mk1 Focus

    Hi all I never think to log in here lol! just to let you know I'm still about and so is my gold Mk1. 132k miles now on the clock and due in for its NCT (MOT) test next month. I've totally rebuilt the front suspension with all new parts. Nice and quiet over the bumps now. I'm away down the country tomorrow, to buy a donor car same year and colour as my own. Anyway ill try to log in a bit more often, I must set up an email notification or something. Other than all that its running like a Rolex, and providing me with very cheap transport. I've a few other jobs planned for the future, valve shims,cambelt and waterpump, PCV valve replacement and fix an annoying oil leak (I think its the sump gasket) hard to believe I have it four years now already. i only do 5k miles a year, so its not getting massive wear and tear, although every year before it has to go in for the test, I always do a few jobs. Trailing arm bushes are next on the list. I have the bushes already and once I have them in, that will be the entire suspension system replaced in the last 2 years with good quality parts. I did the lower arm bushes in the front just two weeks ago, and rebuilt the original arms. pressed on the large and small bushes, drilling out the rivets for the lower ball-joints was a right pain and took longer than the bushes did to be honest. I had it in for tyres and tracking, and when it was on the lift I had a right good poke about underneath. The bloke in the tyre place said it was the most solid mk1 hes seen in a long long time. I'm going to pull all the arch liners out too, and pressure wash it all out and then a good dosing of cavity wax and under body sealant just to try and keep the old girl solid. I'll bang up a few pics soon. PS I'm going to set up an e-mail alert now to remind me to log in from time to time George
  6. i found an unconnected blue multiplug in the dirvers a post today. Tehres only two wires out of it. Anyone know what its for?
  7. Mk1 Trip Compiuter

    Hi all. Ive had a look at the stlak wiring so far. Pin 10 slot is empty. had a look in behind the centre vents and the claocks and dont seem to see it. Car is a 00 Zetec. There was a guide i found before to a blueyonder site that showed how to retrofit the wiring but the link is not working. Any help?
  8. Mk1 Trip Compiuter

    Hi all. Ive had a look at the stlak wiring so far. Pin 10 slot is empty. had a look in behind the centre vents and the claocks and dont seem to see it. Car is a 00 Zetec. There was a guide i found before to a blueyonder site that showed how to retrofit the wiring but the link is not working. Any help?
  9. Been Away For Ages And Don't Have My Van Anymore �

    Hi Saul, back meself after an inconspicious abscence lol. Youll be glad of the little Ka for the winter. I did several winters on bikes when i was a young fella. Bits of you cold that you didnt think could get cold.....rofl
  10. Hi Again

    Hi Salsheikh Yeah shes a really solid old girl indeed. I want to see how long I can run her for. Lucky for me I'm very handy with the spanners (misspent youth with cars and motorbikes)
  11. Hi Again

    I found a bumper for thirty euros.....in the SAME colour. Ill be picking it up saturday week. Its an hour down the road but i dont care as i dont have to spray it. The front bumper was damaged when i got her and is cracked in 5 places. Easier to just rip it off and slap on another one. Happy days, as it always irritates the !Removed! off me walking up to it in the car park at work....
  12. Hi Again

    Howdy all Not been on here in ages, as other stuff going on and work etc. Anyways just an update on my Gold Mk1. Still have it and still going strong. Just passed another NCT (MOT) test on sunday with flying colours. I did lay the spanners to it this time though: Rear ARB droplinks Rear lower TCA's Rear Shoes Rear Wheel bearings Handbrake cable I also have the Inner front wishbone bushes bought just a matter of putting them in. The ones that's in there are starting to split. Sailed through the test though. Just after seeing how the back end tightened up has spurred me on to do this. Just passed 121500Mls now and emmissions are still really really low. Planned work in the near future as funds allow: New front bumper (any irish members know where theres a gold one scrapped let me know) Rear upper TCA's back box (looks to be the original 1 piece ford affair from new on there still lol) I have that vibration Mk1's seem to get under load, So first port of call is to have a gawk at the mounts but I suspect its the carrier bearing on the drive to be honest. The old girl just keeps on going.... chat soon George
  13. Mk1 Focus Obd?

    Thinking about getting an obd lead. Any recommendations lads for me trusty mk1. I'd rather the lead so I can use my laptop...
  14. '06 Tdci Focus Boot Popping Open After Startup

    Thanks boys Shes calling out to me tomorrow. I told her she should have went with a Mk1.....
  15. Hi lads My sisters 06 Focus diesel has just developed this issue this week. The boot pops open just after she starts the car. Any ideas?