bezzawezza

Budding Enthusiast
  • Content count

    33
  • Joined

  • Last visited

About bezzawezza

  • Rank
    Settling In Well

Contact Methods

  • First Name
    Steve

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta (and a Focus)
  • Ford Year
    2013
  • UK/Ireland Location
    Torfaen

Recent Profile Visitors

490 profile views
  1. Needles flickering on startup (plus other weirdness)

    Hi guys, better pictures as requested. Do these look bad then? Whilst a bit full of grease I thought they looked okay tbh
  2. Needles flickering on startup (plus other weirdness)

    I'm not by the vehicle now but will get one later. That's a big dollup of grease on the battery end though. Should that not be there?
  3. Needles flickering on startup (plus other weirdness)

    Is there an easy way to see if something is drawing power whilst switched off as I'm convinced this is what's happening. sorry for so many questions guys. I really do appreciate your assistance.
  4. Needles flickering on startup (plus other weirdness)

    Right, checked the earth cable and it seems fairly solid and okay. Also took the top of the fuse box in the engine and visually it looks fine. (See pictures) Starting to worry it's the cluster or the ECU now as they're gonna prove expensive.
  5. Needles flickering on startup (plus other weirdness)

    Okay thanks for that although ECU problem concerns me! ;) We had a weird code come up in January which is when we replaced the battery but nothing has come up since and no check engine lights. Hopefully you're right and it's the earthing or fuses.
  6. Needles flickering on startup (plus other weirdness)

    That's awesome cheers mate. Sorry to bang on but could that cause battery drain then? I've given the car a 20-30minute run and seems fine again.
  7. Needles flickering on startup (plus other weirdness)

    Sorry one other question. If I give the car a run (so presumably the battery gets charged a bit) the problem seems to go away for a bit. Could that still point to earthing or fuse box issues? It could earthing and fuse box issues cause the battery to discharge? I'm convinced what I'm seeing is because the battery is beginning to drop below some sort of threshold but it's been tested okay along with the alternator. So my theory is that when the car gets a run the battery goes to 100% and the car starts fine. When it drops to 95% the flickering needles starts but it's still enough to start the car. I take the battery to be checked but the run the garage charges it to 100% and it reads fine (along with the alternator). The question then is what is causing the battery to discharge? Could this be the earthing/fuse box mentioned above?
  8. Needles flickering on startup (plus other weirdness)

    When you say passenger strut tower are you referring to the suspension strut or the strut of the car chassis between the front and rear doors? Sorry to be dense. if it's the earth from the battery then it could add up as we had the battery replaced in January and the issue went away for a bit. Possibly the earth worked it's was loose again.
  9. Needles flickering on startup (plus other weirdness)

    Okay, I'll have a look into this. Could this cause the symptoms I've described then?
  10. Needles flickering on startup (plus other weirdness)

    Okay thanks for the advice. I'm very much an amateur though so where would I find the earth cable? Aren't there a number around the car (some in awkward to reach places)? I'm dubious on whether it's a water issue to be honest as, whilst it's wet today and doing it every time, it was also doing it intermittently in June and July when we had that bit of a heatwave.
  11. Hi guys, this has been an ongoing issue for a few months but I hadn't spotted some of the signs until now. It started out with my wife's 2013 Fiesta Zetec occasionally resetting some of the trip computer (average mpg, average speed) for no reason on starting the car and that's continually been happening for months. I've since noticed that this coincides with the needles flickering at zero for a few seconds at startup (which I've read indicates a battery test is in place???) in August I had the battery and alternator checked and was told they were fine. on investigating this further I've read that the 2014 fiesta had issues with Bluetooth draining batteries so I've today switched the Bluetooth off completely. Got in the car an hour later and started it and low and behold it does it again (it started fine first thing when I switched off Bluetooth). Take it for a drive to put an average mpg back on the clock and whilst driving the CD randomly ejects. Take out the CD and return home but now the flickering of the needles happens each and every time the car starts (and presumably the trip computer resets too had it not already been reset by a previous start). ive put the Bluetooth back on - still happens switched off radio on start - still happens switched on radio on start - still happens does anyone have any idea what could possibly be causing this? Are you able to confirm the needles flickering is a battery test? I'm thinking this may end up going to a specialist ford dealer now as my garage didn't have a clue when I've mentioned it previously. i have taken a video of the needles flickering but can't figure out how to upload it sorry. please help, this is stressing me right out now and I'm worried it'll get worse and leave my wife and kids stranded or cause some serious issues.
  12. Having an issue with my wife's Fiesta which isn't big enough to warrant a trip to the garage (I don't think) but is proving to be a minor irritant. Basically when starting the car it will sometimes (probably 1 in 10 or 15 starts) automatically reset the average MPG on the trip computer. Sometimes this will also coincide with a sort of stuttering of the electrics when starting. The car then starts and runs fine so no issues there. I initially thought, and was told, that this could relate to a dodgy battery starting to go but I've had the battery and alternator checked by a garage who have confirmed and shown me the readings that show that those are working fine. Does anyone have any suggestions as to what this could be? I've wondered if it is just a fuse but if so I've no idea which one it could be. Should I just be chalking this up as a glitch that doesn't matter or is it a symptom of something more sinister?
  13. Average MPG randomly resetting

    I was thinking it could be an earth connection or a fuse tbh but I'm not sure where to start as I understand there are a number of earth points around the car. I'll check this one out as a priority on the weekend though.
  14. Average MPG randomly resetting

    That's the same tester I'm using. 14.5 without the car started seems very high though. Are you sure that's correct? As I understand it, when running the car the meter can be anywhere between 13v and 15v depending on the alternator and how you are driving the car.
  15. Average MPG randomly resetting

    I think the cigarette lighter battery checker that I'm using under-reads in honesty and I only ever use it as a rough guide. Consequently I don't think the battery is low quite yet.