AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


lms1703

Budding Enthusiast
  • Content count

    22
  • Joined

  • Last visited

About lms1703

  • Rank
    Member
  • Birthday 01/19/1978

Profile Information

  • Gender*
    Male
  • Ford Model
    mondeo
  1. I hope someone can help. Around two weeks ago the intercoller pipe failed. On the way to the dealer I had to drive the car hard to get any movment. I fitted a new pipe but I still have no real power. I have checked all the pipes and I can't find any issues. I did notice that there was no longer any suction coming from the vacuum diaphragm unit fitted to the turbo. I unbolted the vacuum diaphragm unit and tied the unit forward. I tested the car and the car was back to its old self with loads of power. I changed this unit on the hope that this was the fault but no the fault is still there. Can anyone give some idea. Cheers.
  2. In my last post I think I have a lemon I asked about the lack of power. I have done a load of checks and I have found that the vacuum diaphragm unit is not building up any presure. On the top of the diapragm is a black pipe in the past when I took this off there would be lots of suction but today there is none. I have checked all the pipes coming away from it all does seem to be fine. Could anyone tell me if the diaphragm could be gone and if so can I change just this or do I need to by a new turbo. I have no black smoke and the car still travels at motorway speeds it just takes awhile to get there. Thanks to all.
  3. I have just attached the battrey no joy.
  4. Thanks for advise I didnt notice the light come on but that does not say it didnt. I have taken the pipe off and put it back on but its still the same. I have now taken the battrey off to see if that works. Thanks again. :)
  5. Last week my intercooler pipe broken so I had no power and black smoke. I went to my local dealer for the pipe but it needed to be ordered from Ford. I patched up the old pipe just so I could get to work. This worked fine. On the way to the dealer to collect my pipe it split again black smoke and no power I had to drive in 2nd and 3rd with my foot on the floor just to get the car home. I replaced the pipe and expected every thing to be fine but its not. The question is what can I check I have no black smoke the turbo is working the car will happly driver at motorway speeds its just taking a long time to get there. Hope someone can help. :(
  6. Thanks dave h & mintalkin I will let you know how I get on.
  7. Please can someone help. I have a 02 plate tdci (130) that is not running wright. When I put it under load I can hear a whooshing noise thats gets louder the more I put it under load. I also have a loss of power but it will still travel at motorway speeds but it takes abit longer to get there. I have no lights on the dash. I have a bit have black smoke no grey. I have checked the fin inside the turbo and it turns fine and it does not move side to side. Thanks in advance.
  8. Hope someone can help. I have been told that it is possible to clean a EGR valve if so what is the best way. It's on a 02 plate with no wiring. Thanks.
  9. I am at a loss hope someone can help. My car still has no power. I have had it put on a tester and it came up with P0403 EGR Control Circuit P0235 MAP Sensor Circuit I have change the EGR & MAP sensor but the fault is still there. I have checked the smoke from the back and it is clear. When I drive it hard the car cuts out and a orange coil light comes on. The intercoler pipes look fine. Hope someone can help I am at my wits end. :( I have spoken to the garage today and they have told me that because I have fitted a new ERG valve and a new MAP sensor it needs to go back on the machine to have the ECU rest. Is this correct???
  10. At last I have found were the pipe goes. Thanks 4 the help.
  11. Cheers for that. Would I need to buy a new panel or is there a way of fitting a new lock
  12. Can anyone help. I now need a front slam panel for my car. I have found loads but the lock comes without a key. Can you change the locks over and if so how.
  13. It look about the same but it is on the front left hand side when your looking from above.
  14. Thanks for the advise on the wiring. Would you know if the pipe goes into the top side or bottom.
  15. po235 is turbo boost pressure sensor failure Where do I find this and is it expensive? po403 is as you've got. strip and clean egr and check wiring.. I can't see any wiring on the egr am I looking in the correct place? What is the best thing to clean it with? I know these mite sould like silly questions but I am at a loss and really appreciate everyones help :)