BrightonSam

Budding Enthusiast
  • Content count

    31
  • Joined

  • Last visited

About BrightonSam

  • Rank
    Settling In Well

Contact Methods

  • First Name
    Sam

Profile Information

  • Ford Model
    Focus Titanium 1.6l TDCI
  • Ford Year
    2008
  • UK/Ireland Location
    Sussex
  1. Loss of power/acceleration low range

    Thanks Liam. I was always under the impression that some turbo whistle was normal but that's food for thought. That being said, prior to this lack of power issue when the car was running normally there was also turbo whistle - possibly more so than now. Sent from my SM-G935F using Tapatalk
  2. Loss of power/acceleration low range

    Is anyone able to help with this one please? Sent from my SM-G935F using Tapatalk
  3. Loss of power/acceleration low range

    Hi all, Looking to provide an update and seek some further advice. Following on from above, I have had some further work done, but the car still doesn't feel right. I took the car to my regular garage, initially to get the fuel filter replaced as suggested above. They ran some further diagnostics and narrowed it down to the fuel pressure regulating valve, which was replaced. They also carried out a visual inspection of the boost system and no further splits/leaks were identified. This saw an improvement on how it was driving before, but still not back to how it was originally. I have also had a major service carried out, which included replacing the fuel filter - this was due anyway. I'm still noticing a lack of power in the low ranges, noticeable in all gears but as you would expect particularly in the higher gears. Been doing some reading up online and I'm now suspecting there may still be some kind of boost leak. Previously, I had a turbo whistle which you could hear clearly pretty much as soon as you hit the accelerator. This is now much quieter and only audible when you reach around 2000rpm. From your experiences, would this match what I am suspecting, and what should be my next move? I've got a diesel specialist (Diplock Diesel in Hailsham if any of you are local) who I'm considering taking it to for a leak test - would this be a logical next move. Any other suggestions would be gratefully appreciated if you think I am missing anything else obvious. Thanks again in advance. Sam Sent from my SM-G935F using Tapatalk
  4. Loss of power/acceleration low range

    Cheers for the replies. Funnily enough the engine management light did come on for a week or so before Christmas, but then disappeared. I'm planning on getting the fuel filter changed next week. What do the additives do? Sent from my SM-G935F using Tapatalk
  5. Hi all, you've been great in the past and I'm looking for a bit of advice. My 2008 Focus 1.6tdci is suffering from a lack of power/acceleration in the low ranges (below 2000rpm). Feels very sluggish. Once the turbo kicks in around this point, it's much better - so definitely not a faulty turbo. To give a bit of background, I had it remapped around 18 months ago, which made it much more responsive in the low ranges - that's mainly why this is so noticeable. Just before the new year, my EGR valve blew out on the M25, which I had replaced. I've noticed the loss of power since then, although it could be purely coincidental. I've had 2 further parts replaced - air filter flow hose was split, and the turbo intake pipe and MAF as this was also split. Sadly this has not resolved the issue. The garage also mentioned a fuel pressure fault code, and was meant to replace the fuel filter but didn't on the day - I thought I'd take it for a spin first and see. Question is - is the fault most likely to lie with the fuel filter? It has been a while since it was replaced, and no further leaks have been identified on the boost system. Has anyone else experienced a similar issue, and how did you resolve it? Thanks in advance.
  6. Need Help Id'ing/sourcing This Hose

    I've ordered the silicone part off Ebay for £18.50, hopefully arriving tomorrow so I'll see how I get on once it arrives. Sent from my SM-N9005 using Tapatalk
  7. Need Help Id'ing/sourcing This Hose

    Thanks. So I've searched the part number that was posted earlier and I've got the part in the first picture. The disclaimer about the non-detachable elbow joint which isn't supplied (2nd pic) is now my only worry...seems to suggest I won't be able to fit it as is..? Sent from my SM-N9005 using Tapatalk
  8. Need Help Id'ing/sourcing This Hose

    Exactly how I understood it, not quite sure why he would try sway me back towards Ford rubber parts. Just need to guarantee it is the intercooler hose which I need now, does seem pretty certain though. Just thinking outloud...the leak has also caused oily residue on surrounding components and inside of the lid...could this be the smell I'm getting rather than exhaust fumes? Sent from my SM-N9005 using Tapatalk
  9. Need Help Id'ing/sourcing This Hose

    Thanks MXTS, that is the only reason I'm questioning, nothing to do with doubting the knowledge of previous posters - just want to get it right first time! Friend of mine is a mechanic and MOT tester, although he's only seen photos too reckons it is the intercool hose, but he is trying to steer me away from silicone parts on Ebay and towards genuine Ford parts, saying they wouldn't fit sufficiently to hold the boost pressure...any substance to that? Sent from my SM-N9005 using Tapatalk
  10. Need Help Id'ing/sourcing This Hose

    Nice one thanks. My symptoms are loss of power and huge gushing of air escaping/smell of exhaust fumes. Does that all tally with what would be expected from a split in the intercooler outlet hose? Sent from my SM-N9005 using Tapatalk
  11. Need Help Id'ing/sourcing This Hose

    So is the one in my pic definitely the intercooler outlet hose rather than what I originally thought? Can the hose be sourced on its own? For instance is this the right thing: http://m.ebay.co.uk/itm/FORD-FOCUS-1-6-TDCi-MK2-INTERCOOLER-TURBO-HOSE-SILICONE-AND-C-MAX-MK1-PIPE-BLACK-/301144528326?nav=SEARCH Sent from my SM-N9005 using Tapatalk
  12. Hi all, Just hoping to get a bit of advice. I've got a Focus 1.6 TDCI 2008 mk2. The split hose in the picture below needs replacing, which I believe runs from the turbo pipe to the intercooler. Ford have quoted me £96 + VAT as it appears to come with the rest of the pipe aswell. Can anyone confirm that I've ID'd it correctly, and also suggest any other recommended places I may just be able to get the hose on its own. Seems to just be a right angle. Considering silicone too as I've had the engine remapped. All advice appreciated. Sent from my SM-N9005 using Tapatalk
  13. Does seem steep for what it is! Does the ECU not haved to be remapped then so that it's not looking for the DPF? What would happen if it was just gutted without the remap? Although it would be a bit of fun the increased bhp and torque is not my primary incentive. The garage I've spoken to offered me a standard remap at 109bhp or the better one at 135bhp, so I assumed that a remap was essential either way? Sent from my SM-N9005 using Tapatalk
  14. Not sure I'd be up for the risk, I've only recently had a new turbo fitted due to issues with the previous one so I'd rather keep this one in good shape! Also on balance a more local repairer may be a wise move in case issues arise further down the line but still willing to consider other options if the price and recommendations make it a good option. Sent from my SM-N9005 using Tapatalk