Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About thebaldone

  • Rank

Profile Information

  • Gender*
  • Ford Model
  1. Son's Gal has exactly the same problem! How long did it take them to fix it? I can't seem to find out how to get at the gearbox end of the linkage to reattach it :( I had thought of taking the battery out and then the tray etc BUT it appears that this is part of the engine mount !! If they had to strip that lot out first then I'd be amazed if they did it for nowt :P
  2. Looks like one of the gear linkage rods have come off son's Galaxy. All he can select is 3rd and 4th ! How do you get at the gearbox end of the linkage to re-attach. We thought that taking the battery out and the tray underneath would give us access but it turns out that this is actually part of the engine mount !!
  3. Looking for the white slider on the passenger side of the electric window mechanism of a Gal 1997. Anyone got a local breaker which may have one? Happy to pay postage and cost of item. Ford won't/don't supply this bit and window mechanism is fine except for the lugs broken on this. Replacement is around £100+ VAT for the whole thing!! Tried online and local breakers but looking at £50+ just for a little bit of plastic !! Hoping there is someone out there with a busted motor who has this bit in tact?
  4. No go on that link, only thing they are offering is the complete assembly! Also tried a few on line breakers and they are coming back at £50+ !!
  5. Thanks, I've sent them a request for the part.
  6. Tried local breakers and nothing going. Ebay want silly money for the whole mechanism - which is working fine -- I just need that small plastic bit !! Makes no sense to me why Ford don't sell them separately !!
  7. Need one of the plastic runners for the front passenger side of a Mk1 Galaxy. Tried the main dealer and they reckon you have to buy the whole assembly -- £102 + VAT. Anyone know anywhere which may sell this part, it's the white plastic slider, both lugs have broken so it won't stay in the runner.
  8. After a little collision with a bicycle ! I need to get the door card off the passenger door to sort the window out as it ppears to have come off it rails. Looked for any screws but can't find any and it doesn't seem to want to just pull off?
  9. Was there supposed to be an answer ?
  10. Volunteered to change the plugs on son's P reg GAL this weekend. Lifted bonnet tonight expecting to see them at the front(!) but it appears they are actually at the back out of sight?! What's the best way to tackle this job please?
  11. Looking at fitting a Remote CL to my 97 Gal. Already has manual Cl so can anyone recommend a remote CL kit which will convert mine? I've read somewhere that all is needed is a short duration pulse to the existing ECU to open/close the doors? I did this to a Saxo using an Arrow 5 alarm unit and it worked very well but I don't want to go the expense of one of those!
  12. Looking at the state of the plugs left then I'd say yes! They are in a pretty bad way so I am going to try and get 2 plus a bit of the loom and splice them back in again. Oh what fun!! I have found a link on another forum which shows you how to bypass the ECU altogether if it's gone bad and can't be replaced. All it uses is a single 4 connector relay and other people have successfully got it working fine using this method !!
  13. Gonna try that but the local ones reckon Gal spares are very hard to come by! Looking at the state of the plugs, it looks like the whole area got a dorwning at some time!! Also doesn't help as there are 3 leads on one of the connectors which are not connected at all! Looks like I'll have to get the plugs as well and splice the old wiring in.
  14. Can't seem to turn off the rear fog lights on a MK1 Galaxy? They come on as soon as the sidelights are switched on. Tried removing fuse 10 which says it's for the fog lights and they are still on? If I pull out the headlight switch the indicator comes on just below it but the fogs are already on! Checked all the wiring in both rear light clusters and all looks good. Any ideas please??
  15. It would appear that the central locking ECU should be there ! Hence the no central locking problem. Why anyone would remove it is beyond me !!