• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


dgolf

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About dgolf

  • Rank
    Newbie

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta MK4
  1. Fiesta Mk4 Diesel leak

    Sorry for the late reply. Got the car back. £375 in total <_< £95 to rebuild fuel pump £90 for a new alternator the fuel leak had burned out Couple of hundred labour and other bits such as oil etc. Sigh.
  2. Wiring for fiesta radio

    Here you go... Ford Radio Wires
  3. Fiesta Mk4 Diesel leak

    Hey, No I don't know the cost yet, picking the car up tomorrow evening so i'll let you know then!
  4. Fiesta Mk4 Diesel leak

    Hello, I have/had exactly the same problem. Forgive me for my lack of technical terms but i'm not really that competent with car mechanics! But anyway, originally my mechanic thought it was a leak from the switch (maybe a solenoid) on the fuel line just where the fuel-cut off for the immobiliser is located. The switch was very hard to get at, taking him all day to remove the reinforced protective cowel. It was changed and it was thought the leak was fixed, however it turns out that it was still apparent. Currently, the injector pump has just came back from getting an overhall/rework and the leak is fixed, allegedly, but i can only tell whenever i get more than 250miles out of a tank! So, maybe the problem lies with that switch, or if this is a common fault, then it's more than likely something leaking/a loose connection with the pump!