Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About togos

  • Rank

Profile Information

  • Ford Model
    mondeo mk3
  1. sorry for delay getting back to you all. but computer probs.anyway i took a good hard look in fuse box and pulled out a yellow fuse 60 amp it looked all right but i took off see through cap and very carefully touched the fuse wire and it was i changed it the car now does not get hot enough to start the fans.i left car ticking over for 45min and gage was just under halve still not sure if fans work but temperature all right.SO YOU MUST TAKE OF CAP TO SEE IF THISE FUSE IS GONE.!Removed! i said before there was no sign that it was gone just buy looking.hope this helps someone else AND A BIG THANKE YOU TO ALL THAT REPLIED THANKS JOHN
  2. hi guys and girls. surely someone on this site can tell me a way of testing relays.Or if anyone knows of another reason fans wont come on PLEASE TELL .hope someone can help thanks john
  3. hi iv got mk3 tdci 2001my problems started when bottom water hose split while driving temperature gauge went to red so opened the bonnet and notest radiator fans not on. RAC HOME.Changed hose coolant everything fine until today temperature went nearly to red so pulled over lifted bonnet with engine running and once again i noticed no fans working turned off for 10 mins went home fine iv tested fans with wire from battery and both work fine so i was wondering Howe can i test fan relays. heater works fine so i guess no thermostat not very good with electrics so need step by step guide .THANKES JOHN