robbo123

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About robbo123

  • Rank
    Newbie

Contact Methods

  • First Name
    rabinder

Profile Information

  • Ford Model
    focus
  • Ford Year
    2015
  • UK/Ireland Location
    Lanarkshire
  1. Steering Assist Malfunction on 1.5 diesel focus

    i thought i would provide an update in case it helps others with same issue. I booked into local ford dealer garage,,,,,they could not find what was wrong. The following day I took it for a 280 mile drive without stopping and i got the same message "steering assist malfunction".....I restarted the car several times and still got the same message,,,,,with heavy steering I drove the car for about half a mile and parked in safe place. I contacted the garage that sold me the car (was about 5 miles away). They sent out AA (covered by Ford as car was under 12 months old). AA couldn't do anything and so the car was being taken back to the Ford dealership that sold me the car. We got there just before 6pm and so the staff in garage had gone and no one could do anything until Saturday. In the mean time a courtesy card had been arranged via Ford for me to use. On saturday I was told by the garage that the steering rack needs replacing.....they had ordered it on Saturday....but it won't be fitted until Monday morning. I picked up my repaired car on Monday and drove 280 miles back to glasgow (without stopping)....when I got home, the steering malfunction light did not appear.....so hopefully its all sorted now. Its just odd that the steering rack needed replacing on an 8 month old car that had only done just under 3k miles.
  2. Hi there, I'm new to this and wandering if anyone has had similar issues to me re power steering malfunction on new ford focus? I bought a 2015 focus with less than 3k miles on Friday and drove it 10-15 miles that day.....no issues.. On Sunday, I did a 300 mile journey and nipped into local supermarket near home. When I restarted 5 mins later the message "Steering Assist Malfunction" came up. I restarted it again and the same message appeared. I was only 2 minutes away to get home so I persevered with VERY HEAVY steering.....was really tough....there is no way my wife could have managed it. Once home I restarted and the didn't get that message and steering was fine. I'm worried in case this happens again....and happens suddenly whilst driving? Has any one had such problems with a new focus? I have read about problems on older models and a recall in US....but can't find anything on the more recent model? Appreciate any feedback. Thanks in advance.