Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


MadMalx

Budding Enthusiast
  • Content count

    13
  • Joined

  • Last visited

About MadMalx

  • Rank
    Member

Contact Methods

  • ICQ 0

Profile Information

  • Ford Model 2007 Fiesta 1.4 TDCi & 2003 Focus 1.6
  1. Steering Knock

    My 03 Focus 1.6 seems to have aquired a knock on the steering. I first noticed it when parking in a tight spot and having the steering on full right-hand lock and it knocked when it reached the 'stop'. Since then, I've noticed that the steering isn't as precise as it used to be and on checking the tyres they had worn on the inside edge. I got the tracking checked but it was apparently fine, but the vagueness is still there and now it will knock when the wheels are straight ahead - more noticeable with the engine off. I can't find any play in either the rack, the track rod ends or anything elseon the front end, so am at a loss to what it can be. The only thing I can think of is a fault in the rack itself, but with there being no obvious 'play' I can't be sure. Can anyone give any suggestions what it might be?
  2. Dashboard fault?

    The voltage is 14.3v, seems to be charging etc ok. Would this dash fault stop the car from starting?
  3. Dashboard fault?

    When I turned the ignition on, so that the dash light illuminate, the speedo and rev counter dials moved slowly round to their maximum before returning to their 'rest' position, also the trip meter went back to zero. The car has never done this before, has anyone any ideas what the cause is, and whether it's anything in connection with it not starting?
  4. Cambelt snapped

    Went to start the Focus this morning and got the clunk-whizz of a failed cambelt! How hard a job is it to fix? It's an 03 1.6 Zetec SE engine, with 58k on the clock - Ford dealer told me the belt would be fine till 100k, even though I had my doubts!
  5. Strange Noises from my 2002 TDCI

    If it only does it when the car is on full lock, it could be a cv/driveshaft problem. I had a similar problem on a Focus a while back and we couldn't find the cause- it was knocking on initial pull away, whether forward or backwards. In the end we tightened the bolts holding the stabiliser bar which attaches to the floor and gearbox in the centre of the car and even though they were reasonably tight to start with, it cured the problem.
  6. Problem Start my Focus! - 1.8TDCi 02

    Have you tried taking the key out of the ignition, then restarting? My Fiesta does the same thing and I found that this works - guessing it is something to do with the immobiliser?
  7. My 56 plate Fiesta TDCi seems to knock quite a bit on the rear suspension, the dealer said there was nothing noticeable to them, but I'm concious that it's there and want it fixed before my warranty runs out. I also think there's a bearing type noise on the front end, but again the dealer says they can't find anything. Has anyone here had similar symptoms and managed to get them fixed?
  8. annoying starting issue

    The cutting out/low idle could be down to a number of things, although if the voltage is dropping on starting it might be a tired starter motor or possibly a poor earth connection somewhere - engine to body,body to battery, etc. With the low revs at idle, I would be tempted to try another idle valve, or look for an air leak on a vacuum pipe, etc.
  9. 1999 TDDI 1.8 feels low on power

    I think that code relates to an ignition/electrical fault. It might be related to your lack of power, although you might another problem. Does it feel like the turbo is working?
  10. Diagnostics on P0420 code

    The engine management light has been coming on for a while now on my 2003 Focus (1.6 Zetec SE engine), and after a bit of searching the internet I have found this could be either the lambda sensors or the cat. I used my diagnostics software on the car and found that once the engine had gone into 'closed loop', the pre-cat lambda was switching but the post-cat was giving a steady reading. Problem is that after a few days, when the light had come on again, I re-did this test and found both the pre and post cat sensors were switching with a very similar pattern, indicating a failed cat. Am I right in assuming that the cat might be borderline failing hence giving me the different results?
  11. Hot running 2003 1.6 Zetec SE

    I'm going to order a CHT sensor to start with, then if there's no change I think I might buy a new water pump in case this one is faulty.
  12. My Focus warms up really quickly compared to other cars I've owned, but also intermittently the temp guage goes to the red, then back to normal. The heater is hot, but not over-the-top, but when I plug in my diagnostics the engine is running at 114 degrees celcius, when driving it goes to 134 degrees. It's recently had a thermostat fitted, but when the waterpump was checked it looks pretty new - only had the car for a month so not sure when it was done. It never loses water and there is no pressure build-up in the expansion tank. Has anyone got any ideas what it could be?