• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


mattware49

Budding Enthusiast
  • Content count

    10
  • Joined

  • Last visited

About mattware49

  • Rank
    Member

Contact Methods

  • First Name
    Matt

Profile Information

  • Ford Model
    Focus
  • Ford Year
    2005
  • UK/Ireland Location
    Cheshire
  1. Hard Brake Pedal & Airbag Light

    OK got a servo. How much should I be looking at just for labour. There or there abouts for fitting etc.
  2. Hard Brake Pedal & Airbag Light

    What should the pump drive pin look like. It looked like a massive nail head in the engine head and smooth ended on the pump side. Once pump was removed it was very easy to move up and down. When pressing the pedal down I can hear a slight hiss whilst foot is on the pedal
  3. Hard Brake Pedal & Airbag Light

    Ok so i took the jump and replaced the pump, no difference. i have noticed however that when you press the pedal in the car there is quite a loud hiss from in the footwell, this tends to correlate with it stiffing up so if you do one quick press its fine and stops adequately with 1 hiss. however if you put your foot lightly on the brake e.g. to creep to a roundabout you hear a slight hiss when you touch the pedal and then another hiss then it goes hard. I'm presuming this can only be the servo now, is this a bugger of a job and best paying a garage rather than fight with it? Cheers
  4. Hard Brake Pedal & Airbag Light

    Ok. I've tried the test you suggested and here's the results With servo still in loop the bubbles never 100%stop there is a very slow trickle. It takes a good 10+seconds to get to this stage. With the servo out the loop (unplugged and bunged up (when removing the plug a loud pop was heard which leads me to believe that the servo is holding vacuum)). The bubbles don't stop at all and when turning the engine off approx 10mm "disappears" from your standard jam jar of oil. Thus leads me to believe and I hope you can confirm it appears to be a pump issue? Thanks in advance Matt
  5. Hard Brake Pedal & Airbag Light

    It's engine oil. No loss in brake fluid at all. Must be from the cam area like you say. Where to go from here is the question?
  6. Hard Brake Pedal & Airbag Light

    Ok. I've replaced the pipe and checked the outlet for the pump by completely disconnecting but still doing same trick. Still no luck. Oil is dripping out the pump outlet though. Is this normal or is it likely a pump seal has gone hence poor performance and oil in pump. Cheers Matt
  7. Ford focus mk2 parking sensors

    Hi Guys. I have a 55 plate focus 1.8tdci with factory fitted parking sensors. The parking sensors don't seem to be working consistently. Occasionally you will hear a very quiet (like you need a dogs hearing to hear) humming/high picked noise. Is there a volume control on it or any suggestions where to start looking on this. Cheers Matt
  8. Hard Brake Pedal & Airbag Light

    That's exactly what is happening. For the vac pipe. Can this be a silicone hose and is the check valve a universal part? And can any hose be attached to the pump attachment? Thank you for your help. Really appreciate it.
  9. Hard Brake Pedal & Airbag Light

    Hi Guys, just been out looking at it, don't want to touch the vac pipe really until i get a new one with check valve as its pretty seized on so if something breaks i want to be able to replace it. sussed out a better way to describe the issue if you guys can help any better..... when you have the engine off and pump the brakes and it goes hard, the car does the same with the engine on when lightly pumping the brake to come to a stop, almost identical as to when the engine is off. If just braking quickly or in one press all is fine and car stops as should. anyone have any more of an idea if this helps identify the problem any more, Thank you appreciate the help.
  10. HI Guys, In need of some help please. I have a 55 plate Mk2 Focus 1.8tdci duratorq engine. the problem i'm having is recently (past fortnight) every now and then the brake pedal becomes rock hard and doesn't appear to be effective at stopping hte car, this is only when pressing slowly to slow the car, when slamming on/emergency stopping/harsh braking it works fine. Any ideas where to start looking for a problem, i've heard possibly vacuum check valve or vac pipe maybe? if so any one know where i can order one and how much this would be? Also the airbag light has appeared on the dash, doesn't show up anything using the f-super diagnostic tool, any suggestions. Thanks in advance guys, Matt