• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Tim ST170

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Tim ST170

  • Rank
    Newbie

Profile Information

  • Ford Model
    04 Focus ST170
  1. Front Passenger Side Wheel Problem

    Sounds like it could be yeah. Also worth checking the balljoint where the lower arm meets the hub assembly as these are prone to going and begin to creak/knock on bumpy surfaces when they do.
  2. Ford focus

    This is normal on the later focus' as far as I'm aware, however its irritating if you don't want the aircon to come on. There is a method of stopping it doing this by disconnecting something, but I'm unaware how to do this. A quick solution would be to select the footwell and window instead of only window, as that'll stop this happening.
  3. ST170 thermostat and housing

    Recently upgraded from a 1.6 zetec focus to an ST170, and already the ST170 is giving me problems. It appears to have a slight water leak from the thermostat housing, and also going from the oil and water temp gauges, the thermostat seems to be stuck open. How easy is it to change the thermostat on these? There's no haynes manual but is it the same proceedure as on a standard 2.0 engine (as covered in the haynes). I'm aware theres a common fault where an o-ring goes on the 'stat housing causing the small water leak... anyone else had this problem? Thanks in advance, Tim.