Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


UKChris

Budding Enthusiast
  • Content count

    107
  • Joined

  • Last visited

About UKChris

  • Rank
    Feet Under The Table

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta
  • UK/Ireland Location
    ---------SCOTLAND-----------
  1. Well I thought I would give you an update, just in case anyone has the same issues. Again long story short. Ford did there thing, and it turned out to be software issues, they updated the Bluetooth and voice command software and adjusted some temperature sensor settings, everything is now working as it should be, the fan goes off when the car is locked so hopefully (fingers crossed) no more flat battery. So £100 lighter but at least the old girl is back. Chris
  2. I have had a look for the fuse but so far I haven't found the right one, blooman hard to get those new style ones out. The vent is beside the controls by the drives leg section, if that make any sense.
  3. Hi Thanks for your reply. When I say that you can here a fan, I do not mean the ac fan, I think it is the little fan that samples the air, it goes off when the car door is opened. It's decently by the small vent on left hand side of the drivers side, not the normal heater vent Unfortunately even when the climate control is turned off this thing still runs.
  4. Hi guys Well my 59 fiesta has developed a strange fault, basically something is draining the battery (until it is dead), after a little messing about I have found that if I sit in the car with the key out of the ignition and the doors locked I can her a fan cutting in and out intermittently, this fan is somewhere on the drivers side and I think it is to do with the EATC (but that's a guess), does any one have any ideas on what can be causing this. It is pulling about 1.6A when it is on, when it is off it goes down to 0.3A. Also in addition to that the voice control has gone off, press the button, noting happens. and also just in case it is related every so often when I put the car into revers the AC kicks in on full fans, this is intermittent though. Because of everyone breaking down over the bank holiday, I'll not be able to get Ford to look at it until next Wednesday, so any help or pointers will be greatfully received. Other than that the car is great. :( Chris
  5. Sounds like you may have a sticky calaper. If your going through pads that quickly, you may want to see if kwikfit are still doing there lifetime guarantee. Chris
  6. Just wondering if anyone has bought any winter tyres yet?
  7. If there was a way to get the heater part working. that would be great for the winter
  8. Sorry I have been away i ordered mine from FordPartsOnline, just told him the part number, never mentioned any info about my car, it came to about £35 including p&p I am really chuffed with my new button, just have to find something else to !Removed! on about. Chris
  9. Ok here is an update, I ordered the part on Monday with 3-5 days delivery, it arrived 10am Tuesday, can't beat that. Fitting took seconds as i had left the cable hanging out. The button lights up when press and the ESP light comes on, on the dash, so I am hailing this a sucess. also my finger is healing nicely. So for all you 2009 Titanium drivers who had ESP fitted at the factory, i can answer Yes the cable is there and yes it does work, well on mine anyway. Just need to work out what size steel wheel and snow tyres I need and I will be set for the winter. Thanks to everyone who has posted on how to do this, it was the ESP in the winter that spoiled a great car.
  10. Ok after a little blood sweat and tears I managed to get down to the cable, no one ever mentions that the car requires a blood sacrifice from the back of my thumb before the panel comes off. The cable is there, is there any way of seeing if this is active, or do i just order the switch and see? also has any other titanium owners done this? If only i could read German.
  11. Hi Guys Ok I am a little confused, I have a 59 plate Titanium with ESP, can I fit one of these switches?
  12. I've found that when i leave my lead boots in the house my MPG does go up to about 54 MPG, but it makes me feel old to drive that carefully, so i generally stick to the lead boots. You could always take ford up on there "offer" to monitor your driving style, this should tell you if it's you or the car. Offer = pay us £30, but you get £15 BP voucher. http://www.ford.co.uk/OwnerServices/FordEconoCheck
  13. That's interesting, when I spoke to my local ford guy he was very keen on sorting this for me, especially when i pointed out that a lot of Titanium owners in Scotland would love to switch this of when it snows. He looked into it and told me that there was a lot more to it than changing the panel and adding a switch, apparently we also have to change a number of moduals to get this to work, as will as cable looms etc. He may have been feeding me a line, but I never got that impressions. Chris
  14. I don't know what it is, but i can tell you that mine makes it, sounds like it's coming from the glove box area
  15. Nope, there is a thread about a page down that is from last year, basically the only way you can get round it, is but pulling the fuse, or buy a zetec-s, which you can have a button fitted