Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jellyman

Budding Enthusiast
  • Content count

    44
  • Joined

  • Last visited

About jellyman

  • Rank
    Settling In Well
  • Birthday 12/13/1951

Contact Methods

  • First Name
    Bob

Profile Information

  • Gender*
    Male
  • Ford Model
    mk3 mondeo tdci 130
  • Ford Year
    2003
  • UK/Ireland Location
    Somerset
  • Annual Mileage
    10,001 to 15,000
  1. Hi. I have a Mk3 2.0 130 TDCI mondeo that has done 186000 miles and I am getting a noise from the drivers side of the engine that sounds like a bit of tin flapping about. Someone sugested that it was my air con compressor. Has anyone else had this and if so how easy is it to change it. Thanks in advance for any feedback.
  2. I have a 53 plate 2.0 130 TDCI Mondeo 184000 miles drives great except for one problem. That is I am having trouble with my rear calliper handbrake lever. It sticks on and will not release. I have tried oiling it and moving it back and forth and that seems to do the trick for a few days then it sticks again. It’s not the cable sticking (I’ve had that before). Is there any way of taking the calliper apart and sorting the problem or do I need to buy another calliper?
  3. Hi All I hope you can help me. I have a 53 plate 2.0 TDCI mondeo. Yesterday my nearside dipped headlight blew which in turn blew the fuse. I have now replaced both but now when I switch the ignition on all the dial spin round to max and the MPG. MPH and trip milometer reset themselves to zero. From then on all works well until I switch off and switch on again and it all repeats itself
  4. Try 2361
  5. Try 3402
  6. Try 1121
  7. Try 6332
  8. OK thanks will try it
  9. Thanks I have had a look but they don't look that worn to me. I have taken a couple of pics of it do you think they are the culprits
  10. Hi, I have a knocking on the rear passenger side. I replaced the subframe bushes with powerflex bushes last year so is probably not them. I have just removed the suspension unit and the top plate looks fine. The only thing I could see was that the shock absorber was leaking therefore knackered would this give me the knocking. Any help would be greatly appreciated. Thanks.
  11. Try here www.fordwiki.co.uk/index.php?title=Fuse_%26_Relay_Information