Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


tdci stevie

Budding Enthusiast
  • Content count

    79
  • Joined

  • Last visited

About tdci stevie

  • Rank
    Settling In Well

Profile Information

  • Gender*
    Male
  • Ford Model
    mk3 mondeo tdci ghia 130
  1. Found the leak in the end..., hole in the rocker cover its only plastic so silly design have added pic of affected area, hope this will help anyone else in same boat...
  2. Got local garage to do rocker cover and change spark plugs all fine for a little while then the leak was back.... Took it back to garage and they took it back off and put sealant on the gasket and put back togehter.... few months later leaking again so took it back to garage (they said must been faulty gasket Mmmmm) so they replaced the gasket again and put different colour sealant on.... And guess what its leaking again....!!! My question is what is causing this problem and why...? all of the above work has been done within a year and the car has 80,000 miles and serviced reguarly, and only covered 6,000 miles with these 3 gaskets...
  3. Gonna do the clutch (£230 just for the clutch), i doubt i will do the dual mass its not making any noise, and with the realease bearing/slave cylinder there is no sign of fluid leak under box and thers no problem getting into gear, so hopefully just the clutch replaced at mr clutch will do the job.....
  4. My car is reving when i floor it and the car isnt moving to the revs (until 2-3 seconds later).....? A garage said to me today that the clutch is slipping... Also the cruise control now and then cuts off when on hills..? Are these linked or seperate....? only covered 70,000 miles, never had towing gear or carried any weight...? Stalls probabaly 1 or twice a month if not revved enough when pulling away... does the putting in 4th gear and lifting clutch while staionery trick work to let you know if clutch is knackered...? Would love to trust these garages but they all seem to be after your money worse then !Removed! turpin the highway robber lol..
  5. Scout around either for a cheap hand held diagnostic machine range from £40-£120 on ebay for a half decent one or find some local who offers diagnostics,they will read all engine, abs, airbags for most/all petrol cars from 2001 and diesels from 2004, ford (!Removed! turpin) will charge £85 plus vat to put it on there machine, i ended up paying for a sealey handheld cost me about £180 but times ive used it on my mondy, in laws focus, and my familys vauxhalls its paid for itself.... plus friend of friends you could charge £10-£20 extra beer money...lol
  6. Just double checking where these little vac pipes go, for solenoid on right (turbo 1) top: middle: bottom: Cheers in advance
  7. Took vac pipe off from solenoid valve and sucked on it to make sure the actuator arm moves... and it does it all so holds until i release suction.... Please any help on this problem most appriciated starting to do my nuut in....
  8. A diagram of the turbo and all associated hoses/vac pipes would be great, haynes manual are sh*t for things like that... And if it was the turbo knackered why when i took vac pipe off acuator it made it a hell of alot worse...?
  9. Hi just thought i would start a new thread with added pictures of my problem. When i floor it the rev needle jumps but the car doesnt, if i slowy apply throttle it has plenty of power is do a ton, its the moment a give it a little the car doent respond straihht away. I had to change the big rubber inlet pipe that goes from intercooler to bottom of EGR a while back as loss of power and a hissing noise, so changed that and thought everything would be merry, but not has got rid of hissing noise and slightly improved performance, but still have this boost problem. Have checked the little solenoid vac and pipe (pic 1) for splits and is fine, also getting vaccum from it (when idling) everthing seems to be fine there, chased the pipe to actuator on top of turbo and still no splits (pic 2). I took off the vaccum pipe that goes from vac solenoid actuator and drove it to see what happens and it drives a lot worse....if this test helps Had diagnostic machine put on and there are no stored or pending codes.... Any ideas or help in the right direction would be great....
  10. Could the actuator be sticking ? Still getting problem dont know what area to look at next...?
  11. Checked Vac Solenoid and all clean plus good feel vaccum from it with engine running, vac pipe to actuator is ok no splits or damage, when i pulled vac pipe off of the vac solenoid it made a whoosh noise, depressurising i suppose... Where else should i be looking for this flat spot problem, its definatly got me thinking its a vaccum issue now... Any more ideas most appreciated...
  12. Yes theres 2 in front of inlet manifold, 1 goes to EGR, 1 goes the top of turbo... Are these the only vac pipes i need to be looking at...? The vac pipe goes to the top of the turbo is that the wastegate actuator...? How would you clean out the solenoids....? Like i sais earlier i have not got any stored or pending diagnostic trouble codes showing on my Sealey.
  13. Checked the main intercooler pipe and that is all fine... How many vac pipes are there for the turbo....?
  14. Right i have took off EGR modification i.e blanking plate, and while i was there put in a new air filter. Took it for a spin watched rev gage closer today and the rev needle seems to sort of jump when i floor it past 2000rpm to just under 3000rpm, plenty of power if i dont floor it and increase revs slowy easy do 100.... its this flat spot that confusing and annoying... any ideas help please....
  15. ok will do this this morning, and report back.