AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


owls4ever

Budding Enthusiast
  • Content count

    15
  • Joined

  • Last visited

About owls4ever

  • Rank
    Member

Profile Information

  • Ford Model
    54 reg 1.6 Ford Focus
  1. Cheers!!
  2. Hi all I've got a focus 2012 model 1.6 diesel tdci and have got used to the glow plug light coming on every time I go to start up the engine. Anyway I recently returned from holiday (car had been left in the car park for 2 weeks untouched) turned the key and the glow plug light didn't come on. Starter okay though. It has continued in the same vein for the remainder of this week.....v strange!!?? Is the above normal for new Diesel engines? Bearing in mind that it had been abit warmer than the usual near-zero temperatures (nearer to the mid teens). I'm not aware if outside temperature has an effect on whether the glow plugs are required for the start-up though Thoughts and wisdom welcomed as ever guys (n gals) Andy :)
  3. I have wondered that to be honest, especially the miles left in the tank calc, completely toned down my driving and still won't get 400 miles out of this tank. Nothing spesh on my model other than the appearance pack. Time will tell I think with this issue
  4. UTO FTB :)
  5. Yeh I'm from Sheff, Wednesday fan as you've probably guessed! :) Live in Derby now though since I came to Uni here
  6. Cheers guys, amongst anything I just wanted to check I wasn't being daft and make a prat outta myself at the Ford garage! Managed to get 50 mpg today so I suppose that will do me, driving miss Daisy mind! :)
  7. The air con has been used but not too much, windows are up and not load in the boot. I had thought of the tyres earlier and went to check them, not low at all. Honest John website is really good so thanks for that. Real life MPG (which I must admit is an absolute joke when you read why the EC figures are so optimistic) is between 44-59. Real average around 50, so I guess the car is acting 'normal'. So much for efficiency ey, more like a smokescreen!
  8. Hi guys, I've recently exchanged my old 54reg focus for a 3month old 1.6 econetic TDCi 115 focus (4000miles ont clock now) and I've been driving it for about a month. Reported MPG is 67.3 as an average however I don't seem to be able to get above 50MPG, even though I am following the gear shift recommendations on the computer as close as I can. Anything above 50MPG is more often than not influenced by gravity than 'true' fuel efficiency. I was wondering if anyone has had the same issues? I know that pure urban driving has a tendency to lower overall MPG but I do 40miles per day from derby to nottingham and back. Even long haul distances average MPG is around 50, miles below the comparison within the ford Manual (circa 80Mpg)! I recently turned the traction control off which has boosted the MPG somewhat but all very wierd for a car that has 99% decent reviews. Is this normal for diesel cars to be inefficient and then develop an efficiency throughout their life? Advice or knowledge gratefully received Cheers Andy
  9. The other day i was travelling around 60mph on a dual carriageway and all of a sudden the speedometer needle fell down to around 30mph and then back up to the speed i was travelling at. No cut out of engine or anything...no issues since... No warning lights have come on either, so i was just wondering if this is a common fault and if anyone has any advice to give on this? Could this be a major issue and will an ECU check at a garage point me (or more importantly the mechanic) in the right direction as to how this can be rectified My car is a focus 1.6 edge 54 reg Cheers
  10. Hello all, I have a Focus Edge 1.6, just tripped the 90,000 mile mark and i got to thinking about cam belts cos my mate just recently had his replaced. I havent had mine replaced since i got the car when 4 years back, and to be fair i had no reason to i suppose. So a few questions really just to put my mind at ease - 1) Are there any symptons which the car gives which would potentially flag up that the cam belt has had enough? 2) When the cam belt does go i have assumed it just snaps and thats it? 3) Is there any mileage in asking my mechanic to take a look at the belt? or will this cause more hassle than anything? (Is the cam belt easily accessible for a mechanic??) Any help / advice would be much appreciated Nice one :) Andy
  11. hello everyone, i dont post on these forums very much (which i see as a good thing) but anyways i recently had a service on my 54 reg Ford focus 1.6l Edge. The service found that one of my spark plugs was black and needed replacing. The car has done 80,000 miles so not sure if this is normal. No codes on ECU. The other thing is the people who did my service said i had a code come up last year saying that a code came up (dunt know which one) which diagnosed that the rev meter maybe being affected by the fuel gauge?? Not sure if this makes any sense to any mechanics who come on here. EIther way, they didnt mention it this time and i was abit miffed at this cos if the ECU comes up with a code once, would i be right in thinking that the code wont disappear until it has been remedied? Just got me thinking that the garage i went to maybe trying to pull a fast-one. Cheers Andy
  12. just an idea (and im not a mechanic) but couldnt you do the dashboard trick and see what dtc code is being read? surely there linked in some way?
  13. after being a bit skeptical i went and tried it !Removed! excellent call whoever designed this one - now when i see the fuel warning light come on i can actually tell when im about to run out as opposed to guessing and paying for fuel at an expensive fuel station when i know i can get to one 20 miles down the road p.s just out of interest how long (in miles) do people reckon they have in ford focus edge model 54 reg when the fuel warning does go out? sweepstake ahoy me thinks
  14. Nice one for the advice mate!!
  15. hi everyone first post on here woop woop 1st prob- when i lift the clutch up to change gear the engine makes a squealing sound - it only seems to do this when im bezzin around the place and not when im sunday driving so im guessing that theres summat wrong with the clutch system. Ive done 43000 miles ish and dunt reckon its normal any thoughts would be appreciated :) 2nd thing- Has anyone with this car had any success changing any of the front lights on the passenger side of the car- the battery case is in the way and this seems like a serious design flaw to say this is the least we can do and saves a trip to the garage