• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Apache141

New Member
  • Content count

    1
  • Joined

  • Last visited

About Apache141

  • Rank
    Newbie

Contact Methods

  • First Name
    Shane

Profile Information

  • Ford Model
    S-Max
  • Ford Year
    2006
  • UK/Ireland Location
    Norfolk
  1. S-Max 2.5T stalling

    Hello All, 1st time posting as iv just inherited my mums old S-Max (2.5T), long story short aux belt snapped & took out the cam belt (all valves hit + pistons in a bad way). So we brought a 2nd hand low millage engine for ~£1300. Now the new engine has been fitted and runs (for a while) smoother than the original engine IMO. It has the oil filter housing diaphragm that needs to be changed (screeching noise until the dip stick is removed), can also here the air passing by the dip stick while running. Now the main issue .... it stalls a LOT, if after 2-3 min of running (doesn't matter if its at idle or whatever), the engine starts to loose power and struggle (like starved for fuel or air) until it stops. Its logged the following error codes. P0089 (Fuel pressure regulator performance) P0090 (Fuel pressure regulator control circuit) P0102 (MAF sensor low voltage) P0237 (turbo boost sensor low voltage) I have all of the old engine bits (that was working fine with no errors logged before the CAM belt fail) My question is where to start ? iv done quite a lot of DIY work on cars before (rebuilt a rover K series a few times after head gasket issues) Cheers in advance