• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Davek1995

Budding Enthusiast
  • Content count

    12
  • Joined

  • Last visited

About Davek1995

  • Rank
    Member

Contact Methods

  • First Name
    David

Profile Information

  • Ford Model
    Ford Fiesta 1.25 Finesse 5dr
  • Ford Year
    2003
  • UK/Ireland Location
    Sussex
  1. **Update** After months of looking I have found it. http://www.ebay.co.uk/itm/FORD-FIESTA-MK6-02-08-1-4-16V-WATER-FLANGE-THERMOSTAT-HOUSING-1N1G-8594/263230176812?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2648 Thanks anyways
  2. Hello all, My bracket that holds my ignition coil is badly damaged and only has one screw holding on to the coil, which is badly stripped. I've tried drilling them out which only got me so far.. (Looks worse now too) I'm thinking of changing the whole bracket if it's possible. I can see that it connects to the engine with 2 bolts (I think) and has 2 hoses connected to it for the coolant. My copy of the Haynes manual (page 5B.2) say that it's the "Coolant outlet elbow" however I cannot find any results for this when putting it in Google. I have found this image on ebay of an engine someone is selling, it's attached to it. I'm really struggling on what to do next, can anyone please help me Thank you! :)
  3. Thanks for your help. I took it to my local garage and showed him the problem. It turns out the power steering hose has a clip that came off, causing the hose to bang against the wheel. Quick cable tie and sorted! Plus I didn't get charged!
  4. Did you get it replaced? It drives me mad at work cause the road is quite uneven.
  5. Hello. I'm getting an annoying banging noise when going over bumps and when on full lock (both directions) The sound is coming from the drivers side by the wheel.. Video: Edit: There is only 1 bang noise when going into full lock. In the video I'm slightly moving the wheel out and back into full lock, causing multiple banging noises. Anyone got any ideas or similar problems? Hopefully it won't cost too much to fix :(
  6. Hello, I've got a 2003 Fiesta with an aircon panel similar to this one When I put the fan onto 0 I still get air coming through the vents. It does it on both hot and cold... Anyone got any ideas Cheers :)
  7. Hello all, I've finally taken my triple stack radio out, using a converter kit. I had a JVC KW-R920BT, which sits flush against the rest of the dashboard. Annoyingly the radio kept making strange noises and so did the replacement. I went for a Pioneer FH-X730BT, which works perfectly, but doesn't sit flush and makes it look horrible... Does anyone know of a radio that will sit flush with the dash? It must have Bluetooth Cheers
  8. Hello all, First of all, hope your all having a lovely Xmas I've just installed my new radio using this kit http://www.ebay.co.uk/itm/361463142323?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT I bought a JVC KW-R920BT. Everything connected fine, with the included cables on both the kit and stereo, however I'm getting a very annoying static sound on every source and if the volume is turned down the speakers hiss It's only on the right speaker, but doesn't do it all the time. Mainly when a song changes. Heres a video to the noise I'm using the same speakers as my stock radio. I'm not 100% sure if the problem is due to phone interference, but if it was then I'm screwed. I will try tonight if it is my phone. Anyone got any ideas?
  9. Missing Air Cleaner Pipe? Fiesta 03 finesse

    All fixed! Thanks everyone for all your help. The car seems to be a bit quieter now and I'm less worried that it'll explode!
  10. Missing Air Cleaner Pipe? Fiesta 03 finesse

    Think I have found it! https://www.fordpartsuk.com/shop/ford_fiesta_air_intake_tube_f_1306950_c_751.htm What do you guys think?
  11. Missing Air Cleaner Pipe? Fiesta 03 finesse

    Thanks for the advice! I sent him a text message and he said that he'll pay for the part, if I buy one. I found this on ebay, which looks like the correct pipe. http://www.ebay.co.uk/itm/162201790118
  12. Hello all, I've recently passed my driving test and got a Fiesta finesse which was registered in 03 I noticed about a week after buying it that a pipe is missing. I took it back to the dealer and they said that was how the car came to them and that It doesn't need the pipe. I'd rather have the pipe so I have been looking online for the part, but I can't find it anywhere.. I have attached some images. The manual says it goes to the air cleaner. Anyone got any ideas?