• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Mafiatounes

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About Mafiatounes

  • Rank
    Newbie

Contact Methods

  • First Name
    Rami

Profile Information

  • Ford Model
    Fiesta MK6
  • Ford Year
    2002
  • UK/Ireland Location
    Other/NonUK
  1. Has Anyone Fitted Led Indicator Bulbs ?

    You need a resistor for led bulbs to work properly more so in the indicators. Sent From My Huawei P9 Lite
  2. Lack Of Power, Idling A Little Lumpy Etc

    Any updates on this i have the same on my wifes MK6 1.4, cleaned throttle body, pcv, tmap sensor however still the same, it seems however the exhaust is having a leak.. could this be the culpritt? I would say if there is a leak between the o2 sensors they would try to regulate air/fuel mix causing an irratic idle and or loss off power. Sent From My Huawei P9 Lite
  3. IAC Valve 1.4 Duratec SE

    Thanks all. The pcv valve was checked by myself it still works (clicks), the hose was not split after a quick check. I found out that the iac is incorporated in the throttle body on the fiesta's not on the focus mk1. I cleaned the throttle body, pcv, tmap sensor. I still need to check the brake booster hose or other hoses for possible leaks. It really seems strange i cannot find what is wrong. Maybe the throttle position sensor/electrics are not working. Sent From My Huawei P9 Lite
  4. IAC Valve 1.4 Duratec SE

    Dear all, i just bought my wife a Fiesta with the 1.4 Zetec SE engine from 2003, i am having revs going up and down between 1000-1500 rpm. What i did is clean the throttle body by taking it off (did not help) and also cleaned the PCV which still works well however did not help the cause. Next up on my list was to clean the Idle Air Control can someone please show me it's location on a picture i had a look from top and the bottom of the engine but it seems to be hidden somewhere... Please help thanks in advance! Sent From My Huawei P9 Lite