• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


omerone

Budding Enthusiast
  • Content count

    16
  • Joined

  • Last visited

About omerone

  • Rank
    Member

Contact Methods

  • First Name
    Omer

Profile Information

  • Ford Model
    Focus mk2.5
  • Ford Year
    2008
  • UK/Ireland Location
    Other/NonUK
  1. Strange EGR Problems mk2.5 1.6 TDCI

    Hi all, i'm coming back to the topic with a final conclusion over my 'bad' experience with the EGR valve, in hope that it could also help somebody else out there. Finally it's all solved. After having the second new EGR valve installed from my mechanic, the problem was still there, but the car had a better response for some reason. But the garage had no other clear ideas, so I decided to go to Ford to hopefully come to an end and to stop using the car in this way that for sure would create other problems after a while. So I went to a different Ford garage ( in the first one the chief mechanic excluded the software update of the car and I never really understood that position, it should be a positive thing for every car if a software is improved, like a firmware of any device ). After explaining the whole story they were actually a bit reluctant to take my car in but under my insistance they proceeded to make a diagnosis with Ford IDS. The result was the same, same 3 codes that after deleting were reappearing only after engine off and on again. The mechanic than said that the first thing they must do is to substitute the EGR valve with a genuine one and to install a new software in the car. I was totally surprised of course because this guy had no problems to make the software update but also because he said that Valeo is also not the genuine product, while my mechanic has got from his Ford contact the information that a genuine egr valve was a Valeo and I was quite sure that Valeo valves are originally mounted by Ford because several owners I've asked to could confirm and my original old valve was a Valeo ( same one that Igor has ) and i've got the car with only 60.000 km, so I really doubt that that component was already substituted. Anyway I've decided to take the risk and do the job. The following day it was done and here is the photo of the valve that was installed so really with a Ford brand on it and together with the software update the mechanic said it was solved. I couldn't believe to that and anyway happy that it was solved I've paid 450 Euro bill and jumped in the car to check how it will drive. With big disappointment I've realized immediately that the car was again not that ok, sometimes without boost etc. After some kilometers I decide to plug my computer with Forscan and like in a perfect nightmare I could see again the 3 codes. I than drive back immediately to Ford and tell that I feel the car not ok and ask for another diagnosis and that I want to see with my eyes that the codes are not present in their software. I've raccomended to the mechanic that the codes were reappearing after engine off and on again but he said of course he checked that and that it was ok, but in my opninion he didn't check...so even if they were looking at me and thinking i'm crazy they allowed the re-check and of course found the codes again and only then they became a bit more concerned and focused on the thing. Another mechanic said that of course if this is the 3rd valve i'm installing with same results it couldn't be the valve itself, but he suggested to verify all the electrical harness and connections, but that was meaning to dismantle half car, with many working hours and maybe not finding the problem. But I decided to do that in a hope to solve it and anyway as a last attempt before getting rid of the car for very cheap. And so was done, they unmounted everything from egr valve to the pcm checked every connector and cable and couldn't find anything strange. Only after few hours one of the guys saw in one of the connectors from the pcm that on one pin there was something. He took it off and said it was silicon, probably sealant that they put around the connectors during the assembly or something. Incredibly when reconnected everything and reset the egr the codes were not there anymore. I was also there and couldn't believe. It was solved. So the only possible explanation was that for some reason until the original old egr was there it was working with the original parametrs but once the first new valve was installed it couldn't be programmed because of this one pin not getting in contact properly. So both previous valves, Pierburg and Valeo were fine. Anyway only Ford could solve the problem because my garage would not dig that deep and couldn't install the new software for the car. Ford was also very fair and calculated only another hour of work when in reality they spent minimum 4. Finally here is a screenshot of how the parameters look like now in Forscan so you can see egr valve at 88.5 % at idle and all learnt values for the egr. The egr is also opening and closing 3-4 times after engine off from 0% till 99,5% for the cleaning and self test procedure ( thing that was not happening till now ). The car now is like reborn, full power finally. Another incredible improvement is that the consumption per 100kms that usually I had between 6l and 6,3l has dropped to 4.6l...I really cannot believe to this...maybe I never had the egr ssytem working properly or the new software has some really good improvements. At the end of all of this bad experience I can say the result is still ok, was expensive all in all but my car was saved, at least for now. I could never immagine that a component like the egr valve could condition so much the performance of the car and would strongly raccomend to anybody thinking on managing the valve personally to not touch it until it's very necessary ( like in my case was: stuck open so engine is dying ). To Igor I can say that those not learnt values are not normal, maybe better to fix that before having bigger issues. At Ford thay said that driving for a month or more like I did with the EGR not operating properly will fill the dpf over limits and it even cannot regenerate properly and it gets very, very expensive. If anybody is interested I have a genuine Valeo 700414 absolutely ok for the 1.6 TDCi engine, was only one week in my car, so like new and it originally costed 280Euro. You can check online, that's the price...The ones for 100 euro are copies... Thanks to everybody was helping during these hard days!
  2. Strange EGR Problems mk2.5 1.6 TDCI

    It is not good news...today the mechanic from the garage will contact a guy in Ford to try to understand a bit better what could be behind this all...they also want somehow to understand better..I was quite lucky that the garage decided to fit a genuine Valeo without additional expanses for me because for them was also all very strange...Let's see what will happen with Ford. I'll maybe try to re-measure the VREF or the new Valeo. I don't know which system the garage is using, forgot to ask but for sure it's not Forscan and neither Ford IDS, it's a kind of portable tool in the dimension of a laptop, looks as a profesisonal tool that they use for all car brands... But how to explain a different behaviour of the car? I have more power, it's like it always was in acceleration now, but the codes are still there...Any idea if those codes could be self-erased after a while? Or absolutely not if the PCM reads maximum opening at 70%?
  3. Strange EGR Problems mk2.5 1.6 TDCI

    Hi all, Igor thanks for the data and for the confirmation that the egr valve should open up to 98% and not 70% like in my case. Anyway the guys at the garage today substituted the Pierburg valve with a genuine Valeo model that you can see here in photo ( and of course performed the reset procedure ) So it looks the same like the one Andy has got ( for some reason a number is missing on it - *9672880080* ) but there was also the box with the model number 700414 and not 700412 as should be from the list from Valeo that i've posted yesterday. Anyway it didn't solve the problem: all the 3 DTCs still present any time the engine is shut down and ignition on again and in Forscan still showing maximum opening up to 70%, but with the following differences - the car has got back the full power like was not completely there with the Pierburg, much better response in every moment of acceleration - the valve now is operating ( as possible to monitor with Forscan ) even without deleting the DTCs, thing that was not happening with the Pierburg So the thing is not solved, I'll try to use a bit the car without deleting the codes in order to complete some driving cycles but at this point the visit to Ford must follow as it looks like a PCM / software issue that only they can probably solve... Anyway Igor this valve you can find as a genuine piece also on ebay like here ( just pay attention that the brand with barcode and numbers is there ): http://www.ebay.co.uk/itm/Genuine-EGR-Valve-1-6-HDi-D-TDCi-Mini-Citroen-Fiat-Ford-Peugeot-Volvo/222217263280?_trksid=p2047675.c100623.m-1&_trkparms=aid%3D222007%26algo%3DSIC.MBE%26ao%3D2%26asc%3D20160323102634%26meid%3D4b012e5865ba4720a0d893ff5f5cdf0a%26pid%3D100623%26rk%3D2%26rkt%3D6%26mehot%3Dpp%26sd%3D171990646920 and as far as I know the reset procedure must be done with a diagnostic software like Forscan or other ones. Anyway you can change the valve also without resetting the parameters, the new valve will simply use the same from the old one.
  4. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Igor, just to give a short feedback before you buy and replace maybe for nothing your working EGR valve....the DTC you are getting it's not surely an EGR valve problem...could be quite more than normal carbon build up in the whole EGR system ( that's not only the EGR valve, there's the cooler and several pipes ) and maybe it should be cleaned... the EGR is for sure to be cleaned or substituted when stuck open or closed, so it cannot at all operate properly. I was getting this error also but the car was working fine but only when the valve was stuck open for some reason it needed to be replaced and there is where all of my problems started. Tomorrow my garage will replace the Pierburg valve with a 'genuine' Ford one that I guess will be a Valeo. I was suggesting to the garage to try the 700412 because here http://www.valeoservice.com/data/master/webfile/12915640124FCF68B668BA9.pdf?rnd=570 is the only one offically listed by Valeo for the Focus Euro4, but the garage has some contacts directly in Ford so they will get this genuine one and we will see what this means. Tomorrow probably i'll be able to tell you more. Actually you have my same engine and year and the numbers on your EGR ( 9685640480 and 21604679-9 ) are also on my old valve. Would be great if you can check from Forscan which values in percantage you are getting when commanding the valve to fully open ( you can do this also with only ignition on ). Strange that you have 'Not Learnt' values for the old valve...you or anybody else tried to reset the adaptation values of the valve?
  5. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Andy, thanks a lot for this...it confirms even more my theory...the genuine EGR for the Focus is Valeo...the number on yours anyway differs from my old one....do you maybe have the 90hp engine? I have already asked the garage to provide the Valeo 700412 Egr and will post the results.
  6. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Andy, thanks a lot for this feedback, I think it really says a lot. Is it possible for you to find out which EGR was last installed? Maybe you have it on an invoice or something or you could just take a picture of the cap where the brand and the model N. is! Thank you very much
  7. Strange EGR Problems mk2.5 1.6 TDCI

    only a detail I found on official Ford repair manuals: http://workshop-manuals.com/ford/focus_2004.75_07.2004/mechanical_repairs/3_powertrain/303_engine/303-08c_engine_emission_control_1.6l_duratorq-tdci_(dv)_diesel/description_and_operation/diagnosis_and_testing/engine_emission_control/ "If a new EGR valve is installed. The base setting (closed position) value must be configured to the PCM. This is initiated using WDS. If the base setting is not configured to the PCM, the setting from the previous EGR valve will be used and the control function of the EGR system will be incorrect." Could it be that not official Ford diagnostic softwares are not able to really initiate the base setting of the new valve into the PCM?
  8. Strange EGR Problems mk2.5 1.6 TDCI

    I'm not sure technically, but it seems than that due to higher voltage in closed position, the new valve is not getting enough current to move...But than how is it possible to move it from Forscan? Because this lower current limit in the ECU is being forced? Anyway it's clear that without a working Valeo i'll not find an answer... I'll come back with hopefully a final verdict...
  9. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Peter, today I had some more time and decided to re-check the measurments of the valve because I wanted to re-check this old valve. And than i've realized that yesterday I've inverted the direction of the pins, so the ref voltage anyway is ok because comes from the two 2 pins on the extremes, but the VOUT measurments were totally wrong...I'm sorry....but here is what i've discovered new: New valve: VOUT closed: 1,16 V ( 1,25 V when I delete the DTC with Forscan ) VOUT open: 4,13 V Old valve: VOUT closed: 0,28 V VOUT open: 4,77 V For the old valve i've again moved manually the fork from one extrem to the other. So this somehow makes more sense, but obviously there is difference.....could this be a confirmation that the valves are not the same?
  10. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Peter, yes it's really bad luck with old valve, but this also explains the reason why it was not working, something went wrong in the circuit and now as you say appears as a totally open circuit to the ECU. The only thing to do would be to open the new valve and see if when commanded with Forscan to 70% it's really fully open or not, but I don't want to do that now because anyway the valve is new and I should have some warranty on it in case it will be replaced. The EGRVR should actually be the EGR duty cycle in Forscan ( anyway I don't have idea what a EGR duty cycle is ) and the EGRVP the valve position. It's clear that for some reason the new valve doesn't respond correctly to the basic settings in ECU. I stopped today at Ford and talked to the main guy in the garage ( I live in Graz, Austria ) and explained the issue and asked if we could try to make a software update of the car and he said better to not do that, could introduce other problems (????). But when I told him that I got a Pierburg EGR he was looking at me in a very strange way and he told me that they fit only original parts to the cars and original means Valeo. The reset of the egr adaptions the garage did with their diagnostic system first and than I also did it with Forscan...there are basically no other instruments in Forscan to do that...I don't have idea if it's possible to this calibration manually with some other instruments. I think with the measurements I at least can be roughly sure that the ECU is operating ok and try to ask to the garage that performed the valve substitution to get a Valeo valve that we could just plug without fitting to the engine and see what will happen. I'm really wondering how andystephenson solved the thing with same symptoms...
  11. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Peter, thanks to your input I was able to make some measurements by myself. I,ve found the old valve, was still at the garage. So i measured the new and old valve in open and closed position with ignition on and engine off. For the new valve I've commanded it with Forscan ( works also with engine off, but only after deleting the DTCs ) and for the old one, as long it's somehow damaged and doesen't move, i've moved manually the fork from one end position to the other ( i've separated the electric part from the mechanical ). All the measurement i did with the connector plugged and using as back probe pins some sewing needles stolen to my wife...:)..worked perfectly. Here the results: New valve ( Pierburg ) VREF: 5,26V VOUT valve closed: 2,79V ( 0% in Forscan ) VOUT valve open: 0,57V ( 70% in Forscan ) Old valve ( Valeo ) VREF: 5,42V VOUT valve open: 12,3 V for some seconds than goes to 0 when DTCs are appearing and MIL is turned on VOUT valve closed: 2,78V I don't know how to interprete the data, but it looks at least that the ECU is sending the signals correctly and interpreting correctly if the EGR is stuck closed or open and storing correct DTCs for the 2 different problems. But how to explain the sticking closed new EGR? And the 70% open in Forscan related to the 0,57V? Should that voltage go to almost 0 to totaly open the valve? I did also a couple of screenshots of Forscan while commanding the EGR valve from Forscan ( so first screen shot egr closed - second one open ) with engine running at idle Concerning the Throttle valve mentioned some posts ago, i've noticed that the EGRTV_FLOW is never changing and the EGR_TV is not changing a lot during normal city drive...is that ok?
  12. Strange EGR Problems mk2.5 1.6 TDCI

    And pins 2 and 3, is this the power supply to the egr motor? so 12V? thank i'll try it out and post the results
  13. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Peter, thanks for the nice drawings and the back-probe advice, i'll try. So if I got it right I should have 5V between pins 5 and 1 and a Vout between 4 and 1? I'll ask the guys in the garage if the old EGR is still around....but that one was stuck open, does this influence the Vout that I should get from it?
  14. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Peter, tried today to command also the throttle valve for Forscan, infact is possible to command the EGR valve and also the throttle valve, while engine on idle. When i was changing throttle valve value from 0 to 100% the engine was changing sound and stalled-died when value was 100%. I think the throttle valve is ok. I've identified it's position, should it be good to dismount it and give a clean? I could measure for the 5V if they are coming in on ignition on, but how can i do that? Can I unplug the connector and simply measure what comes on the cables? Which pins should I measure? Thank you very much for helping
  15. Strange EGR Problems mk2.5 1.6 TDCI

    Hi Peter, thank you for the reply. I think you are right concerning the EGR test after ignition off. I remember, when everything was working fine, when turning off the engine clear 3-4 click-clack sounds were happening: this was the EGR test and cleaning operation the ECU was doing by closing and opening some times the valve. This is not happening anymore. All the checks you are suggesting are good points and should be checked. I'm afraid at the garage ( it's a small local one ) there's nobody with good electrical capability to check all the wiring till the ECU. How to check the throttle valve? Which parameter values should be ok in Forscan? I don't understand how other valves can influence the electrical EGR valve test that takes place when the engine has stopped already... I was checking all pipes for leaks also with engine working but seems all fine....I found a bit of oil in the Turbo intake coming from the rocker cover down to the intake, but the mechanic from the garage said this is nothing for what he normally could see on this type of engine on Fords, Peugeots, Citroens... Yesterday I tried to manually command the EGR from Forscan with engine on idle ( only after clearing the famous DTC errors ) and it opens from 0 to 70%, and I can clearly hear difference in engine's sound while doing that, so the valve is moving, it is not stuck, but it opens only till 70 not 100%. I think this is the problem...the test when turning off the engine cannot be performed and subsequently the valve is not activated on the next ignition on. I'm not a mechanic but my feeling is that is a purely electric/electronical problem. I suspect that Pierburg valve is not fully compatible...I found on the internet that that Pierburg is comparable to the Valeo 700444 model ( mounted on Fiesta, Fusion ) while Valeo lists only the 700412 as compatible for the Focus Euro4. I know that the engines are pretty much the same between all of those models but probably there is difference in the electronics. I think I need to find a good car electrician and check the wiring ( i've inspected the connector by myself, looks like new ) and than think ahead.