Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


gaz1250

Budding Enthusiast
  • Content count

    7
  • Joined

  • Last visited

About gaz1250

  • Rank
    Newbie

Profile Information

  • Ford Model
    LX
  1. coil pack?
  2. it should pull off but there might be a bit of plastic u hav to push in while pulling if i remember correctly
  3. Are you sure its not a VSS sensor prob
  4. Just had another look at noticed a noise from the alternator? Could this cause vibrations?
  5. Long story but here goes....got a focus 1.6 it was runnin perfect until the other week when it started to misfire new coil but no diff so turned out to be water in the spark plugs (a think that came from the engine bay being cleaned) changed the plugs and leads and got rid of all water. 2 days later the car struggled to start when cold and then temp sensor went...so after replacing the sensor the cold start problem went and no water returned sorted but now the car vibrates when idle (sat at lights etc) and gets worse when you use your lights, wipers etc. Help this car is drivin me mad!!! Thanks in advance
  6. Yeah Im pressing it twice.
  7. Hi My central locking is working fine but the boot release button in the car and the boot release button on the key remote wont open the boot. You can only open the boot by using the key manually. Could this be a fuse if so which one as I would have thought the central locking uses the same fuse and that is fine. Any help please?