• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Dan_C

Budding Enthusiast
  • Content count

    30
  • Joined

  • Last visited

About Dan_C

  • Rank
    Settling In Well

Contact Methods

  • First Name
    Daniel

Profile Information

  • Ford Model
    Fiesta
  • Ford Year
    2007
  • UK/Ireland Location
    Greater London
  1. I decided to change my front wiper blades on my 07 Fiesta. I got a pair of Bosch wipers, bit of a task to remove and fit the new ones on, it has a clip mechanism. Which side is the driver's side "spoiler" meant to be? I think its below the blade as shown: http://tinypic.com/r/mmevqh/9 Also I can't get the passenger side blade off and I didn't want to break it, might need to just switch the wiper and not the actual blade? I'll need to change it soon as the new one will be more worn in when I fit the passenger one.
  2. Click sound when engine is running

    So put the car in on Monday, back at dealership. Picked it up earlier today. New brake pads have been fitted as I presume they were wearing and rubbing against the rotor. No more squeaks. Air con light not coming on was user error, didn't realise I had to turn the fan on for it to work. Cig lighter barrell socket thing wasn't working earlier but it just needed a clean. Windscreen washer button on the indicator switch was a bit dodgy but I just have to press it forward slightly and it works fine.
  3. Click sound when engine is running

    Took it back to the dealership I bought it from earlier, they took it for a drive and diagnosed the sound as coming from the brake pads being dry, for the squeak sound, not the air con. So they said to come back next week and they'll take apart from the brake system to inspect fully, then apply grease to it?
  4. Click sound when engine is running

    Tried turning the air con on and off but the button doesn't stay lit up when I push it in so it could be linked to that?
  5. Click sound when engine is running

    Ah, yeah that might make sense, I had the car seats valeted on Thursday and they were still slightly damp after so I had to leave the engine running and blast hot hair into the car with all doors/windows shut to help dry them out a bit more. When the blower fan was on there was no clicking as I stood outside the car for 10 minutes. But the blower fan isn't the same as the air con inside is it?
  6. Have had my new Fiesta Climate for nearly a week now and whilst its driving nicely, there's an irritating intermittent clicking sound (like a smoke alarm that needs its batteries replacing) whenever I'm driving. I've tested to see if its a result of braking but I don't think its linked. I can't tell what part of the vehicle its coming from but its really annoying me. The cambelt has just been replaced so its not one of the belts being faulty surely? Or a worn joint somewhere?
  7. Anti-freeze/Coolant levels

    I checked the coolant levels in the expansion tank this morning and it was well below the min line. So I poured in a fair bit of coolant to take it halfway between min/max, as shown. Chucked in a bit of water too to mix it up. Started engine and let it sit for 5 minutes. No adverse reaction. Took it for a drive for about 11 miles, again seemed ok and checked the levels again and its the same as it was before. I should be alright now? Also the other photo shows the black hose pipe that should have been clipped on to the expansion tank in the first place which cause the water to steam out.
  8. Anti-freeze/Coolant levels

    I wasn't at home when I discovered it and my mate helped me out with a bit of water. We ran the engine and it went down a little so we topped it up again just between the min/max mark. So if I add a splash in there it should be alright.
  9. Anti-freeze/Coolant levels

    I'd say there's about 20% coolant in there, water wise alot more, as I said earlier enough to get me home and the temp sensor wasn't going crazy. But I think I need to top it up.
  10. Anti-freeze/Coolant levels

    Not this one, I think its concentrated. As there's water in the expansion tank to replace the coolant that leaked out I'm obviously not going to just pour it in to the top am I?
  11. After acquiring my new Fiesta today, fitted with a new expansion tank I noticed the small hose or tube that connects to the engine had come loose as it wasn't clipped into place causing the water to evaporate blowing steam out underneath the bonnet plus loss of coolant. Whoever fitted it didn't clip it in. Very lucky I spotted this early on. Topped it up with water just to get me home, I do have a bottle of anti-freeze, but how much are you meant to put in to mix with the water? Its supposed to be 50% of each isn't it? Tomorrow morning I'm going to top it up when the engine is cold, there is still some coolant in there but don't know how much to pour in.
  12. Minimum litre engine for motorways

    Well I don't want to pay for two cars to be insured. I know of some insurers that may let you have 30 days tide over insurance to allow you to sell the car in that period. Its still taxed for another 6 months. Just with the new car I'll be insuring I want to transfer it to that, but still looking to shift the old one.
  13. Minimum litre engine for motorways

    LOL I went back today to look at the car again with all the repairs done, and had a peek at the boot size. Its really not that small as you say it is! It'll easily hold what I usually take if we ain't got the van. My old car was a certain german brand (not sure if its a curse to say the name on here!) and it was a 3 door. It easily fitted two guitarist's rigs and a bit of drum hardware. The main boss guy wasn't there however to do the driveaway insurance and I didn't my existing insurance documents with me so I decided to come back tomorrow. Need to speak to him personally about the repairs as his assistant wasn't much use. Only thing is the old car is still on the road and covered by the existing insurance, I'm still going to try and shift it but if I transfer the insurance over and it gets damaged by chavs/thugs its done isn't it? I know there'll be an admin fee for changing vehicle but it is still cheaper than buying new from another company?
  14. Minimum litre engine for motorways

    Lol we split the gear up between 2-3 cars, so I'm not taking everything. The drummer has his own car thankfully, I'm not taking his kit! Haha. Usually I'll take a coupe of guitar amps, guitars and pedalboards, maybe some merch boxes. And 1 other person.
  15. Minimum litre engine for motorways

    Hmmm not sure, I'm currently doing less motorway driving than I used to. Maybe not every weekend but at least once a month I reckon. It's only if the van we usually travel in isn't available, or if I'm working late and have to meet the guys at the venue. The rest of the time it'll be short trips of less than 10 miles. Normally to the van which is 4 miles away from me lol.