• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Sellis26

New Member
  • Content count

    1
  • Joined

  • Last visited

About Sellis26

  • Rank
    Newbie

Contact Methods

  • First Name
    Simon

Profile Information

  • Ford Model
    Mondeo
  • Ford Year
    2006
  • UK/Ireland Location
    Yorkshire
  1. Hi there I am new to this site so here goes. I have a 2006 mondeo tdci 115ps with a cold start niggle. When the engine is cold and starting up the engine fires up straight away. It has new glow plugs. But when the engine is cold and idleing the engine judders and idles unevenly with a clanging from the back top of the engine rocker near the turbo. Once the engine is warm the noise eases and the idle evens out tried injector and fuel cleaners but doesnt work. Cleaned egr no difference. Also cleaned inlet still no difference???? Anyones help will be greatly appreciated Thank You