AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Donnaw

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Donnaw

  • Rank
    Newbie

Contact Methods

  • First Name
    Donna

Profile Information

  • Ford Model
    Mondeo titanium 2.0 estate
  • Ford Year
    2010
  • UK/Ireland Location
    Wiltshire
  1. How would I know if it's an incomplete Regen? It would be nice to solve this as the smell more than anything is really anoying/worrying
  2. No warning lights or anything.
  3. Every time its on a long journey at a speed of 60-70mph. Let's say I'm on an hour's journey the smoke can happen 2 or 3 times. The smell once started doeant seem to go. At times I have to open the window.
  4. Im quite sure it's from the exhaust.
  5. Hi all, About 6 months ago I purchased a 2010 Mondeo titanium 2.0 diesel estate. The mileage is now just over 100K Absoukty love the car but recently I've noticed a couple of things that I'm concerned about. Firstly the car starts fine from cold, no error lights and seems to drive well. When warm and generally when on a run 50-70mph I occasionally find what i can only describe as fumes in the cabin. This smell comes and goes on long journeys. I also notice grey smoke coming out of the exhaust this cones and goes . Please note I dont always notice both of these symptoms at the same time. When I notice the grey smoke if i open the car right up the smoke gets worse for 10 or so seconds and then disappears. If I dont open the car up it continues to smoke. Once the smoke has gone I still notice the smell from time to time. I have also found when i see the above symptoms the idle seems very off. Probably miss firing at idle. Again this goes away All of the above isn't seen when driving around town or when cold. Only when the car is on a run these symptoms occur. I have been reading loads about grey smoke etc and a lot points to leaky injector. What do you guys think. Any advice will be appreciated. Thanks in advance