• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Wilcox

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Wilcox

  • Rank
    Newbie

Contact Methods

  • First Name
    Chris

Profile Information

  • Ford Model
    Galaxy
  • Ford Year
    2009
  • UK/Ireland Location
    Yorkshire
  1. 1.8 Tdci P0202 Injector Open Circuit

    Did this ever get solved? Having similar issues!
  2. Smart Charge Alternator Issue

    I'm having similar issues. New battery and alternator but still get battery light on occasionaly. Puts out 13.7 volts when light is on.
  3. The alternator on my ford galaxy failed after a small fuel leak. I had the battery replaced by the rac who told me the alternator was failing so i got it replaced at halfords. Since then i still get the battery light on with maybe every other start-up. The battery shows 13.7 volts when the light is on and 14.7 initially when the light is off. Looking around on forums it sounds like a smart charge issue? Had it back to halfords twice, both times told they found some 'loose connections' but its still doing the same. Any ideas much appreciated. Can supply more info if needed.