AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


carpetman1967

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About carpetman1967

  • Rank
    Newbie

Contact Methods

  • First Name
    mark

Profile Information

  • Ford Model
    1.8
  • Ford Year
    2009
  • UK/Ireland Location
    Worcestershire
  1. Focus Mk2.5 stereo 6000

    What size are these mate
  2. Focus Mk2.5 stereo 6000

    I had enough of the shocking dim sound of the Ford 6000 I had in my MK2.5 . I bought a single din facia plate and fitted my old Pioneer CD/Radio . The sound is so so so much better , just goes to show how shocking the standard head unit actually was .
  3. Focus Mk2.5

    May I ask ... do you get a lot of engine noise at motorway speeds , mine is a 1.8 petrol and is dreadful !
  4. Focus Mk2.5

    Thanks for the replies all ... its not so much road noise , more of engine noise . I used to own a MK1 Focus saloon 2.0 Ghia petrol , that was so much quieter engine wise at motorway speeds . Begining to regret selling the old one now .
  5. Focus Mk2.5

    Hi everyone , firstly im new here to the forum so hello everyone . I have a problem with my 1.8 petrol Focus , its a 2009 model . For sometime now I have had an issue with a vibrating dash etc on tickover . Car drives fine although I do find it noisey at motorway speeds . Doing some research on here people point to a possible engine mount failure , the one near the expansion tank circular in shape ... fluid filled apparently ? I took off the expansion tank to try and look at the mounting ... it looks a little perished and on closer inspection , the soft centre has a hole in it . I can put my finger in it . Has this mounting failed would you think ? If replaced would that make the engine less noisey at motorway speed also ?
  6. Focus Mk2.5

    Hi everyone , firstly im new here to the forum so hello everyone . I have a problem with my 1.8 petrol Focus , its a 2009 model . For sometime now I have had an issue with a vibrating dash etc on tickover . Car drives fine although I do find it noisey at motorway speeds . Doing some research on here people point to a possible engine mount failure , the one near the expansion tank circular in shape ... fluid filled apparently ? I took off the expansion tank to try and look at the mounting ... it looks a little perished and on closer inspection , the soft centre has a hole in it . I can put my finger in it . Has this mounting failed would you think ? If replaced would that make the engine less noisey at motorway speed also ?