Pete Dyble

New Member
  • Content count

    1
  • Joined

  • Last visited

About Pete Dyble

  • Rank
    Newbie

Contact Methods

  • First Name
    Pete

Profile Information

  • Ford Model
    Focus
  • Ford Year
    2008
  • UK/Ireland Location
    Worcestershire
  1. Thought some of you members may benefit from my experience with 2008 Focus 1.6 tdci. It started a stuttering/hesitation which came and went - no fault codes for warning lights. Some times it would stall the car, sometimes it would be brief and car ran on with no problems. No driving reason for the problem, fast or slow, uphill or downhill, cold or hot, it would happen for no apparent reason. Checked into local garage who thought it was DPF so had it changed at £500 with no change so had they said it was the injectors so paid out over £1k to have new ones and still the same. Mechanic said to get rid of car as it could cost thousands to trace the problem and also the turbo was whistling so that needed changing. I am not the type of person to offload a problem to some unsuspecting buyer so decided to tackle it myself. Bought a new Turbo inner part (£80) and used the same casting, cleaned out all pipe-work of all the oil crud. Removed the oil-feed pipe from engine to turbo and thoroughly cleaned with petrol and compressed air, also blasted air into engine oil gallery. So good oil flow to turbo so that should last the life of the car, incidentely the car had done 91k miles. Still no difference so bought second-hand fuel pump (£60) of a car which had done 42k miles. While engine in bits, changed timing belt, water pump, idler and tensioner pulleys (£77) and ancillary belt (£13). Also stripped EGR system out, which was in a awful state. The end coming from top of engine was at least 50% blocked with crud! The cooling jacket part was full of soot so probably not reducing gas temperature effectively. likewise ERG valve. Cleaned everything manually and with carburettor cleaner. Made sure EGR valve was operating smoothly and rebuilt everything. Took off every sensor I could find and cleaned with carb cleaner. Put back together and it ran perfectly on motorway and other roads for an hour or so and then hesitation and then stop! Called RAC and when they came an hour later, the car started as though nothing had happened! RAC checked the system and still no faults although it did show intermittent low fuel pressure. Car drove home in fits and starts. Ordered fuel pressure sensor. Haynes manual says you have to replace rail and sensor together at £300 so took off existing sensor and checked part number and ordered new one off ebay for £26. Put it back together and it is running perfectly and smoothly so dead chuffed! I hope this experience helps someone who has same problem and does not know where to start. My opinion is that the main problem (apart from turbo) was poor maintenance throughout its life, especially regular oil changes, dirty EGR system and fuel pressure sensor. The other work done would not cure the problem but saved a fortune while engine stripped.