• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Ancient Mariner

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Ancient Mariner

  • Rank
    Newbie

Contact Methods

  • First Name
    Dave

Profile Information

  • Ford Model
    Mondeo Mk. 4 Hatchback
  • Ford Year
    2008
  • UK/Ireland Location
    Dublin
  1. Mondeo 1.8 TDCI (2008 model) Rattle

    Oil and coolant levels were correct, first things I checked when I got the car home. I put my oil pressure gauge on this morning and it reads 40PSI at tick over and increases with additional revs. Before I put the glow plugs back to check the oil pressure, I did another compression test (cold) and got: 1: 460psi, 2: 320psi, 3: 320 psi, 4: 300 psi. Took the rocker cover off and everything looks ok there, will remove the head tomorrow, got too cold today and I'm getting too old for this sort of thing now....
  2. Mondeo 1.8 TDCI (2008 model) Rattle

    It starts, but rattles like mad, the oil light goes out when running. The oil pump is behind the crank pulley. I wouldn't expect there to be more than around a 10% difference in the compression results between cylinders. I have an oil pressure test kit, once this storm passes over, I will see what the results are.
  3. The boss was on her way home on a 200 mile run and around 50 miles away, the engine started rattling and so she called me. We got the car recovered back to the house. I did a compression test this morning and got: Cyl. 1 = 610 PSI, Cyl. 2 = 415 PSI, Cyls'. 3 & 4 around 300 PSI. Any idea what the compression should be? I will take the head off in the next day or so (weather depending) and see what the story is. The car has around 150K miles on it, the timing belts were done at 120K miles and up until this happened, was running well. The alternator, water pump, idlers' and aux. belt have all been replaced in the past 12 months, the only thing not changed was the oil pump (do these fail without warning?). There are/were no warning lights and no MIL codes.