• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Rikesh

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Rikesh

  • Rank
    Newbie

Contact Methods

  • First Name
    Rikesh

Profile Information

  • Ford Model
    Fiesta Titanium
  • Ford Year
    2008
  • UK/Ireland Location
    London
  1. Fiesta Titanium 2009 not blowing hot air

    Thank you for the replies. I went over a bump yesterday and it started working all of a sudden. Flap closed fine and started heating again. But again today didn't work. So the flap opens and closes but doesn't work all the time so might be as stated above. Thanks for the replies, will post again here if I find a fix.
  2. Hi everyone, This seems to be an issue posted couple of years ago but didn't find a solution. Apologies for my restricted car knowledge but keen to learn. Basically, I used to press the MAX button on my heating control unit and hot air used to blow within 10 seconds. Now, no matter what temp the car is set to, even at 30 degrees the car still blows cold air even after the car has been driving for hours. I've been told by Halfords that it's the "flap" which sounds right as when I used to turn the heating on there was a clear recognisable sound like a flap closing after 2 seconds and then the car would blow hot air in seconds. Now there is no such noise when I turn the heating on. He said along the lines the flap should close and blow hot air and open for cold air. At the moment its not closing? I've been told by one mechanic that I should just change the entire heating unit or something along those lines. If it is this "flap", which parts would I require to order? Thanks for looking! Rik