AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Mark Williams

Budding Enthusiast
  • Content count

    24
  • Joined

  • Last visited

About Mark Williams

  • Rank
    Member

Profile Information

  • Gender*
    Male
  • Ford Model
    Mondeo 2.0TDCI
  • Ford Year
    2004
  • Annual Mileage
    20,001 to 25,000
  1. Thanks for your help with this - much appreciated. Apologies, but when you say the MAF sensor....?
  2. Any thoughts on what I can do next?
  3. I've just tried it and it says DTC None
  4. I have a trip computer so know what you mean now. I'll try it this afternoon / evening and see what happens. I assume I just switch the engine off after I'm done?
  5. Also, once I've been through and found any codes, do I have to cylce through all the different checks (by pressing the reset button) or can I just switch the ignition off once I've found the codes?
  6. Thanks - I'll give that a try. To check, by the reset button do you mean the one next to the mileometer that I use to reset the trip mileage?
  7. Well scrap the egr valve thought I wad getting mixed up-it was my wife's car that had that. So not sure why it's juddering. The mpg is dropping too which I guess is related. How would I do a diagnostic check?
  8. I have a 54 reg 2.0TDCI Mondeo and I've noticed in the last week or so it seems to be juddering at about 2000 revs. I even think (although I may have pressed the clutch/break) that it casued the cruise control to switch off as happens when you break or press the clutch. It's not a major problem - doesn't happen all the time but I don't know if it's something to be concerned about? It had a new EGR valve recently - could it be related?
  9. From the dash display
  10. I have a 54 Mondeo TDCI. I have had for a while my mpg about 57-58 and am getting about 620-650 miles out of the tank. However, my mpg is now up to 59.4 and I'm getting about 580 miles - same journeys, same style of driving but quite a big difference. Anyone know why?
  11. How do I replace it?
  12. Yes. I thought it might have been the cable but it seems not.
  13. I have a Mk3 Mondeo and I regularly use a USB lead to charge my phone, which I use for satnav. For a while this worked great and the phone would charge whilst the sat nav was in use. However recently the phone will charge, but when I have satnav on too, it drains the battery rather than charging or even holding the charge. I tried different USB cables and 12v to usb connector and still have the same issue. I know it's not the phone as I tried it successfully in my wife's Skoda. Any idea what might be the problem? Faulty fuse?
  14. I have a 54reg Mondeo and for the last few weeks the boot door has not been staying open. When I open it, it just drops down and closes - I have to hold it open. Any idea how to fix this? I can't see any obvious screws etc to tighten.
  15. I had this on my 2004 Mondeo a while ago and it just stopped. My guess was a stone in the wheel or something.