Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


paramaniac

Budding Enthusiast
  • Content count

    121
  • Joined

  • Last visited

About paramaniac

  • Rank
    Feet Under The Table

Profile Information

  • Gender* Male
  • Ford Model 2009 Focus Zetec S 1.8 Petrol
  1. 2009 1.8 Petrol - How Much Oil For Service?

    Ah ok, I'll check.
  2. Just a quick question: what quantity and type of oil is required for a routine service for a 2009 1.8 petrol 125hp? Am I right in thinking 6L of 5w 30 is correct? Such as: http://www.ebay.co.uk/itm/Genuine-Ford-Oil-5W30-Formula-F-6-Litres-Full-Synthetic-/230865867220
  3. Focus 1.8 Zetec "squeak" On Cold Startup

    Duncan, did they replace the belt and the tensioner or just the belt? When they diagnosed mine the car was still under warranty and Benfield Ford (Harrogate) tried the "wear and tear" trick on me. But if you look at the Ford service schedule for the 1.8 petrol, the aux belt is not supposed to be replaced until 100,000 miles. So for it to become faulty at 2 1/2 years old and 25,000 miles, there's obviously an issue or crap parts. I pointed this out to them and they replaced the belt and tensioner under warranty.
  4. Focus 1.8 Zetec "squeak" On Cold Startup

    I had a similar issue, fixed by replacing the auxillary belt and tensioner.
  5. Focus Zetec 1.8 Petrol Tickover High And Rising

    I had this issue with my car (see info on left). It turned out to be a faulty auxiliary belt tensioner which needed replacing along with the belt.
  6. 2009 Focus Zetec S

    Yeah might consider getting some non-genuine ST 18" alloys if Lewism won't give his up :) The alloy spokes on that red ZS look thinner than the genuine RS alloys. Personally I hate black alloys! I like what he's done with the exhaust though, I want to do the same but on one side only.
  7. 2009 Focus Zetec S

    I think RS alloys would look mint, and yes would be very interested :)
  8. 2009 Focus Zetec S

    Likewise Lewism, although you have the nicer alloys :( I looked at buying some but they are way too expensive to buy new, about £700 + tyres!
  9. 2009 Focus Zetec S

    The aux-in port is on the top of the glove compartment, just a hole surrounded by a grey disk, doesn't really look like one but it is! Mine had a faulty auxilliary belt tensioner which they replaced under warranty, along with the aux belt itself. I think it's quite a common issue. Have a listen to the engine starting and running when cold. It will make a clicky/squeeky noise if it's on the way out. It also caused an intermittent problem when slowing down and disengaging the clutch, the revs would increase steadily until pretty high, then drop back down to normal. Also check for rust caused by the rear window washer pipe rubbing on the bodywork at the top of the boot.
  10. My Steering Just Got Really Stiff!

    PS: it's a known fault, see the TSBs on here: http://www.fordproblems.com/tsbs/Focus/2006/
  11. My Steering Just Got Really Stiff!

    The MK2 has hydraulic steering but an electric motor pump which moves the fluid from side to side. This pump would stop working intermittently on my old car. Local Ford dealership quoted about £400 to replace, however I got a 2nd hand pump online from a newer model for about £120 then paid a friend to fit it for about £50.
  12. Dodgy Revs And Idling 2009 1.8 Petrol

    Turns out it was a faulty auxiallry drive belt tensioner. Local Ford dealership replaced this and the belt itself under warranty and not had any issues since.
  13. Dodgy Revs And Idling 2009 1.8 Petrol

    Thanks Gregg. I just did your test and the revs did drop slowly to about 2000 hovered a bit then went down to about 900. I can't get the issue to reappear on cue. It's just sometimes when slowing down to standstill, clutch disengaged, and the revs go up!
  14. Starting Issuel (1.8 Petrol) Focus Titanium

    I have this issue too: http://www.fordownersclub.com/forums/topic/30181-dodgy-revs-and-idling-2009-18-petrol/page__hl__%2Bidle+%2Bcontrol+%2Bvalve__fromsearch__1 Has anyone solved this problem?
  15. I've had some issues with the revs of my car for a while now. After starting from cold, the idle revs would be about 1100rpm and then settle down to 900rpm after a few mins, then down to 700-800rpm when warmed up. This seemed a bit high. The issue was that when it was cold and you pressed and released the accelerator pedal, the revs dipped really low, sometimes almost stalling. So I took the car to a local Ford dealership and they said they ran diagnostics and reset the idle parameters etc on the car's computer. So nothing manual. Now the car still idles at the rpms above, but the dipping revs issue when pressing the accelerator has gone. However another intermittent issue has arisen whereby when I'm driving along and then slow down to a standstill, braking with the clutch disengaged, the revs go up to about 2500 - 3000rpm! And then once stationary, go down again. My question is, does this sound like an idle control valve problem? I don't know if my car has one?