• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


cornfrog

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

  1. 1.8 td mk2 wont start

    Have you checked for leaks? I just had a similar prob and i found a damaged "O" ring on the fuel line. Changed that and it now runs perfectly.
  2. escort 1.6 zetec surging

    Hi guys. I'm looking for some help with my 1.6 escort 98 ® zetec. When i start it up, the revs rise to about 2000 and drop, but it's much worse when i drive it. The revs increase dramatically and often stay high, pulling the car along. The only way to bring it back down is to kick down on the peddle hard. I can't find any air leaks or damaged vacuum hoses and the throttle cable's not sticking. The water pump and cam belt were changed recently. I have pulled out and cleaned every plug i can see and blocked off the vacuum hoses. The only thing not done is the fan sender switch. It's not working so i put a temporary bridge on it to keep the fan on till i can get the part tomorrow(Monday). The only thing so far that's changed anything was when i pulled a 3 wire plug off a little black unit on the r/h side of the throttle body. The revs went through the roof. I found a thread on this site that explaining a problem like this one, but it's a bit too technical for me. Can anyone put in basic terms and save me from the dealership prices. I'll keep adding as i go and hope it sparks an idea with some one lol. I've been told to clean the idler valve. Can anyone confirm that this could help? I removed the idler valve and put a live feed to it and it has a slow soft click and the piston only moves a tiny bit and very slowly even after a can of carb cleaner through it. So, it looks like i need another one (£106 from fords) Here's hoping it cures the surging. Got the new idle valve and fitted it. The tickover's a lot better and the surging has gone so it's now drivable but the revs are still slow to drop. They come down a few seconds after i take my foot off the peddle and they drop fast but i'm still waiting for the fan switch so it's running cold all the time. The problem with the revs was caused by a little air valve front r/h side of the engine was blocked. I cleaned it out with break cleaner, and it's now running perfectly. Hope this can help some one else with the same problem. I'm not getting any response, am i doing something wrong? If i am, sorry, i'm new to this. Thanks Hugh Ps. It's a lot worse when i put it in gear and drive off. When I'm not moving it behaves a lot better. Can the clutch cause this type of problem? (sorry if that sounds stupid)