AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


peanuts

Budding Enthusiast
  • Content count

    23
  • Joined

  • Last visited

About peanuts

  • Rank
    Member

Profile Information

  • Ford Model
    03 mondeo tdci 130
  1. found this place just for mondeos got lots of very usefull info http://www.fordmondeo.org/forum/index.php?referral/48533/
  2. ta muchly chris will try that when it gets atad warmer
  3. Yet more on this ever increasing puzzle out today went on motor way car fine until for no reason starts to judder and shake at 65- 70 in 5th misfire only happens between 1900-2400 revs in 5th in all other gears doesent happen ? ? ? ? ? .Gentle throttle presure eases it just lost now total puzzle realy beging to suspect the ecu is duff and just cutting the engine at random just happens at random totaly lost any confidance in it ! Does anyone have any ideas ? At all ? Please ?
  4. Funnily enough was staying in arbroath for the whole of the xmas break when the fault manifested itself so much the same conditions would only start with a jump start below 3 degrees wonder if the glow plug circuit staying on at that temprature was what was killing my battery ? Anyway starting fault now gone started first try this morning -3 so the reprogramme seems to have worked on the injection now to find what keeps bringing the fault light on i have noticed a small and i mean small amount of diesel around no1 injector possible leak from return pipe ? Could this cause the limp mode to trip when that injector asks for sustained fuel flow during long periods of accelaration in higher gears and not show in short bursts in low gear ? As the return ciruit probly not needed during short sharp bursts ?
  5. would this also cause cold starting problems as well apparently the fault codes read that the injectors needed re programing and nothing else ? would think the crank sensor wouldnt show untill it completly failed ?
  6. just had my tdci 130 in to have the injection sorted after being stuck in limp mode for some considereable time .informed that all for injectors needed re programing and are sorted got to pick it up 5 miles down the road accelerating along the M602 clunck power drops off dreaded flashing glow plug light is back ! , pull up swicch off then on clears it then off we go car all right in the lower gears will hold hard acceleration revs all the way to 4500 .in 4th /5th accelerting around the 60-70mph mark 2500- 3000 rpm does it again strange ? back to garage on monday any one any ideas as they havent wondering if anyone else has had this on any of the ford 2.0 tdci engines (maybe time for a forum just for this engine as its spread across the range rather than having to look through each different model)?
  7. if that dont work try your dealer they will do it for £10
  8. check that its not sligtly over filled with oil diesel engines can run on a bit if there slightly over full as they burn the exess oil if they are way over filled they can run on to destruction ! think chris is right about the gearlinkage bush or is it possible an engine mount on its way allowing the engine to rock on switch off and the linkage to knock have you had any gear selection problems ?
  9. halfords oldham £625 all done in 24hrs bargain
  10. Airlock ? Headgasket ? Check where your pipes to the heater go through the bulkhead especialy when car hot and pipes expanded get the engine hot turn the heater up full fan on full then top up ! .Also check oil for water and water for oil sign of headgasket failure ? Run very very strong anti-freeze mixtre 80% this will flush a lot of the crap out of your coolant system run for a couple off days like that then empty coolant flush both ways with hose then refil as befor should sort coolant system out .
  11. Ta mate was thinking along those lines myself was looking more for schematic wiring diagram or something along those lines as there aint one in the haynes for the glow plug circuit any body have or know where i can find something like that ? Would be a real help to trace the fault
  12. just replaced my glowplugs on my 2003 2.0 tdci after persistant problems with fuse blowing ! replaced all four partly to be sure and so i didnt have to take the inlet manifold off again anyway fuse still blowing so looks like i have a deeper problem was wondering if there are any common causes of this that i have to look out for eg timer relay connector blocks etc help ?
  13. Know ford want £200+vat per injector then need coding £80+ you could try pfjones of stretford 01618724755 £126+vat for recon or £168+vat fitted & coded good luck
  14. thanks found it on wiki its the fuse for the glowplug circuit ;(
  15. what like banning smoking from public places or hunting with dogs ? Never make the statuet books them ? Nothing would supprise me from any of our currunt polatitions tory labour or liberal !