Jump to content


Community Status Updates


Photo

SteveGeoffH

Welcome to the Ford forums GeoffH :)
Dec 12 2012 09:05 PM
Photo

SteveJammie710

Welcome to the Ford forums Jammie710 :)
Dec 12 2012 08:24 PM
Photo

Stevedavid28

Welcome to the Ford forums david28 :)
Dec 12 2012 08:20 PM
Photo

Stevetaxipaul

Welcome to the Ford forums taxipaul :)
Dec 12 2012 08:14 PM
Photo

memoryweaver

Sprinkling. Sonning Common, Oxfordshire, UK. A cold, cold frosty day today, with just a light sprinkling of http://t.co/3gQ7U8UP
Dec 12 2012 07:46 PM
Photo

SteveOurweecountry1995

Welcome to the Ford forums Ourweecountry1995 :)
Dec 12 2012 07:07 PM
Photo

StevePudd

Welcome to the Ford forums Pudd :)
Dec 12 2012 07:04 PM
Photo

SteveMooreMaster

Welcome to the Ford forums MooreMaster :)
Dec 12 2012 06:40 PM
Photo

Stevecoops206

Welcome to the Ford forums coops206 :)
Dec 12 2012 05:59 PM
Photo

SteveNeilham

Welcome to the Ford forums Neilham :)
Dec 12 2012 03:52 PM
Photo

SteveBigdeal1970

Welcome to the Ford forums Bigdeal1970 :)
Dec 12 2012 02:31 PM
Photo

Stevechelsea steve

Welcome to the Ford forums chelsea steve :)
Dec 12 2012 02:22 PM
Photo

nickgrego

I have a 2006 mondeo st tdci. I have plugged it into a diagnostic box this morning and an egr valve code came up. low input. I went to check and the connector wasn't plugged in so I plugged it in and am now getting a stuttering at lower end of revs or when changing down gears and putting on a bit of power. can anyone help please?
Dec 12 2012 12:39 PM
Photo
Photo

SteveLaura KA 1994

Welcome to the Ford forums Laura KA 1994 :)
Dec 12 2012 11:26 AM