Search the Community

Showing results for tags '2007'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Ford Owners Club
    • Review your Ford
    • Discount Scheme
    • New Member Introductions
    • Was it you!? FOC Members Spotted!
    • General Ford Related Discussions
    • General Chat
    • Ford Guides
    • Show off your motor!
    • Car Insurance Discussions
  • Ford Models
    • Ford Fiesta Club
    • Ford Focus Club
    • Ford Mondeo / Vignale Club
    • Ford Mustang Club
    • Ford KA / StreetKA Club
    • Ford Kuga Club
    • Ford Edge Club
    • Ford B-Max Club
    • Ford C-Max Club
    • Ford S-Max Club
    • Ford Galaxy Club
    • Ford EcoSport Club
    • Ford Fusion Club
    • Ford Puma Club
    • Ford Escort Club
    • Ford Sierra Club
    • Classic Ford
    • Ford Transit Club
    • Ford Ranger Club
  • Buy & Sell
    • Club Cars For Sale
    • Ford Parts For Sale
    • Classifieds
    • General Items (Non Ford Related)
    • Wanted
    • eBay Finds
    • Buy & Sell Archive
  • Traders
    • Opie Oils
    • Mountune
    • Burton Power
    • Puma Speed
    • Revo
    • Visit Owners Club Insurance Page
    • Owners Club Finance
    • Advertise Here
    • Evans Halshaw ST-3 TDCI Deal
  • Ford Modifications and Projects
    • mountune Discussions
    • Photoshopped Ford Photos
    • Ford Project and Build Threads
    • Ford Modification Discussions
  • General Forums
    • Ford Owners Club Meets & Regional Discussion
    • Maintenance / Servicing / MOT Discussions
    • Dealer Problems & Consumer Advice
    • Technical Knowledge
    • Wheels & Tyres
    • Detailing your Ford
    • Audio & Electronics
    • General Site Requests
    • Computing, Gaming and Geeky
    • Dash Cam Videos
    • Ford Motorsport
  • Back Office
  • Ford How-To Guides

Categories

  • Ford Reviews
  • General Ford Guides - Modern Fords
  • Ford Fiesta Guides
  • Ford Buyers Guides
  • Ford Focus Guides
  • Ford Fusion Guides
  • Ford C-Max Guides
  • Ford S-Max Guides
  • Ford Ka Guides
  • Ford Mondeo Guides
  • Ford Kuga Guides
  • Ford Galaxy Guides
  • Ford Puma Guides
  • Ford Escort Guides

Calendars

  • Community Calendar

Categories

  • Articles

Found 21 results

  1. Hi Guys, Hoping for a bit of help. About an hour ago I got into my car and drove it for about 5 minutes. I have just tried to start my car up in order to get home however it's not starting, none of the electrics work, and it won't lock via the remote key. I managed to unlock via the key at first but now nothing seems to work. Has anyone ever came accross this before or have any advice on how to get my car started again? Kind regards Jack
  2. Since I bought my ford a few months back I noticed that the aux is very loose and barely plays my music, any ideas on how to fix the problem?
  3. Exterior grey trim

    I've recently bought a 2007 ford focus and ice got a query regarding the grey exterior trim, such as the bottom part of the bumpers and the grey trim just underneath the boot door. Can these be replaced with anything a bit nicer looking? Or is it literally a case of having them removed, sprayed and reattached? Tia
  4. Illegal Tyres?

    Hi everyone, I have an important question... My Ford Fiesta Style 1.4 TDCi, was fitted with two types of tyres, the front ones were 195/6015, the rear ones were 185/65X15. After suffering a flat rear tyre, I took the car to a local "tyre specialist", who told me not only that the tyres of my car were incorrect, but they were illegal to drive, as my speedometer would show incorrect values, because it works on calculating revolutions per minute on the axle, so, a smaller or larger tyre would give different and incorrect values on the speedometer. He also said that the car should have not passed an MOT with these tyres. He offered to change all 4 tyres and he fitted on both the front and rear axle some 195/510X15 tyres, which I asked him to do. I believed what he said, as he offered to write on my invoice that the tyres previously fitted on the car were incorrect, which he has actually done. As I had bought the car only recently with a full year's MOT, I contacted the car dealer who had sold me the car. But he replied to me saying that the "tyre specialist" gave me false information and charged me for two extra tyres which were not really needed. Who is right here? Thank you in advance everyone, Kind Regards, George
  5. Good morning fellow ford fans. I have just purchased my second mondeo 2.2 tdci st. My first one was sadly written off after a member of the fire service busy on his phone plowed into me. It is a 2007 on a 56 plate only has 79000 on the clock, has had loads of work done recently, bearings shocks, breaks tyres. everything seems to be ok. but the Sony head unit flickers? Ie the lights on it seem to flash on and off, not rapidly at first, but it does gain momentum the longer I'm driving. Please help me me fix this issue, a Google search found one result which didn't help, but I'm sure if I knew the real name of the problem id get more results. Thanking you in advance.
  6. This is a bit of an ongoing problem with my 2007 Mk6 Ford Fiesta (semi-automatic transmission, if that makes any difference...). It's extremely intermittent; the last time I had an issue with it was probably about six months ago, and it's started fine every time between then and now, but every now and again, when I turn the ignition key, instead of turning over the engine just makes this long, pronounced "wheezing"/grinding sound for as long as I turn the key… A mechanic I took it to one side he simply cleaned some of the battery terminals with a wire brush and that seemed to alleviate the issue, but I'm wondering if that was actually a fix or just a temporary thing/coincidence. Lights/wipers/everything works fine and it's a -1yr old battery so I'm assuming it's not that? This short video will hopefully explain what happens better than my text could: https://youtu.be/hYDvo1zApEc Anybody know what that sound is?? Could it be the starter or something?
  7. Roof bars- Need Advice

    Hello, I was looking to get some roof bars for my focus (mk 2 hatchback 2007 zetec) for a camping trip. However I wasnt planning on spending a fortune as I will probably only use them once a year. I have been offered some but they are off a mk 1 focus I was just wondering does anybody know if they will fit or am I going to let the moths pit my wallet and buy some. Any advice/guidance will be helpful ☺ Thanks Matt
  8. Hi. When I pull off turning right with half to full lock I get a chattering sound which indicates worn outer cv joint, I can undo the lower arm ball joint nut and lower it out the way, undo the bolt going into the cv joint but for love nor money can I get the cv joint to slide out of the hub! I tried a hub puller to push the joint out but it's seized solid! Any tips or ideas how to get the cv joint out of the hub? Thanks in advance Paul
  9. Hi, I got an '07 Ford Fiesta Zetec with the 6000CD. I have bought an pioneer SPH-DA120 head unit along with fascia, adapters, etc. But how can I pass my iPhone USB cable from the rear of the head unit around to the front. Also the headunit comes with a wired Mic which I would like to have on the drivers side of the dash. And a GPS antenna needs to go on the top of the dashboard to work 'properly'. Basically, how can I get all these wires out from behind the headunit? Thanks
  10. Evening Everybody. I hate only joining a forum to ask a question but I am looking for some advice with my 2007 (57) Focus. Wife went out in the car yesterday morning and the front wipers are no longer working - I immediately assumed that it was either the fuse or the linkage (my old Punto back in the day constantly had wiper issues). So far I have checked the fuse (Fuse 129 iirc) and it appears to be fine, I have checked and I am getting just under 12v output from the wiring loom (11.9v) and checked for any visible signs of damage/water ingress on the loom but couldnt see anything. I have tried two replacement motors from a local breakers but neither worked - the exact same as before. When I attempt to run the wipers I can hear the fuse box making the "ticking noise" that I would expect. Other functions from this stalk appear to be working without issues (rear wipers and front water jets) and all other electricals are working from what I can tell. I have had a look through the forums and it appears that people have had this issue with various different sources of the problem and hoping somebody may be able to assist with troubleshooting further. We have been discussing upgrading to Mondeo in the next month or so and really want to avoid spening cash on the car. Thanks Mark
  11. My New Car

    Hello everyone, I'm new to these forums and have been looking at them for a while. Only just joined now due to getting my first ford, got a Ford Fiesta Zetec S 57 plate as my 21st birthday present, what does everyone think?
  12. Got my new fiesta now after my 55 plate was written off. Got a few ideas of what I want to do although it probably wont be anything major like some build threads. Any Ideas appreciated! :) Things I've done since I got it: Transfer stereo with new fascia.Transfer wind deflectors What I'm thinking about next: Colour coding trim along doors, boot, door handles and wing mirrors. Spraying front grills satin black as they are a faded grey in person(look way more dark on camera)Install hands free.Dual Mobius dashcams hardwired.Rear Parking sensors.Possibly double din touch screen stereo. Either android tablet, china double din, anything really.
  13. Hi, I've had this issue for a while now, probably since before Christmas last year, in the winter it really struggled to start, after turning the key the starter would turn the engine over but it would turn over slower and slower but sometimes it would suddenly really pick up pace and fire the engine up. I replaced the battery and it seemed to go away I've been using the car less anyway. Now what I'm finding is still get the slow-ish turnover but also after a drive and the engine is hot/warm when i try to restart the engine just coughs and spluts and rattles and shakes then cuts out, does it a few times but then fires up fine. Here is a video of it happening; https://youtu.be/WkYW0JdpYBU I've read various other posts on forums and there seems all sorts of stories some ending with replacing the starter motor and some relating to DMF. My DMF was replaced about 50,000 miles ago (at 81k, I'm now on 127k) so dont suspect it of being that, so I've ordered a new starter motor. Do you guys think it could be starter motor? And also, does anyone have instructions on how to replace starter motor, its a mk4 2007 ('57 plate) 1.8 TDCi estate. Hope you can help. Thanks Gavin
  14. Hi Wondering if anyone could give some clarity on the blank plates next to the front and rear de-mist buttons? I plan to connect a jack extension lead from my glove box through the back of the dash and drill a hole through one of the blank plates and bring it through there, however once I opened the blank plates I unexpectedly found electrical connections to the back of them??? I believe one of them could be for airbags however was is the other one for or is it just left and right airbags? Thanks
  15. Bluetooth In The 2007 Focus

    Hi guys. My Bluetooth doesnt appear to be working properly on my Focus. I have the voice pack and my phone connects to the bluetooth but when a call comes in nothing happens? The phone buttons just mute and I cannot find any reference to bluetooth on the radios menus (checked all sub-menus). What am I missing here? Thanks.
  16. Hi all! So I've recently bought myself a 57 reg ford focus 1.6 (100ps) style. I'm happy with the car apart from this steering wheel vibration issue. The wheel seems to start vibrating from speeds of 30mph onwards, definitely worse at 60~75mph. Haven't gone any faster. At lower speeds the vibration is noticeably worse whilst lightly braking. Had all four wheels balanced & the tracking done which I believe remedied the issue ever so slightly but now I'm out of ideas...I think the car was stationary for a period of like 2 months whilst at the car dealer and I've read tyres can develop "flat spots" but the tyres visually look normal. I'd appreciate any input ☺
  17. Hi All, I've recently purchased a 2007 Fiesta TDCi with 35k on the clock and think I may have got more than I bargained for. A bit of background on the car - it is one lady owner from new, has only covered 37k and has full service history (not Ford). In general, the car is in excellent condition and appears to have been well maintained. When I purchased the car, the lady told me that the car overheated intermittently at around 70 mph. I took it on a test drive and was unable to replicate the problem despite several attempts. She said that the garage had told her that the thermostat was the likely culprit. Anyway, as I was driving it home on the M25, the temperature gauge shot up so I quickly pulled over. The car cooled down almost immediately and the needle plumetted back to half way. I drove it again and kept it at 50 mph with no issue. I was able to drive at 70 mph with the heaters on full and the windows dropped for the hour long drive home. I had the thermostat changed and the problem persisted...this to me suggests that I may have bought a bigger problem. So my questions are... 1) Has anyone experienced anything similar on the TDCi engine? 2) Can anyone offer any advise on the likely culprit? I'm arranging for a pressure test to be carried out on the engine next week as I've been told by a mechanic friend that the engines are the same as the Peugeot and may have a head gasket issue. I'm expecting head gasket or waterpump to be honest, but would rather save time and money by getting some advice from the forum. Any help is much appreciated, Best wishes, Mark
  18. Hi, I have a Fiesta Zetec 57 plate. I am trying to check the solenoid in the tailgate because the boot lock mechanism isn't working when I try to use the button on the dashboard or the button on the key fob. My question is how do i remove the panel on the inside of the tailgate to get to the solenoid. I've unscrewed the three screws but the panel is still stuck rigidly to the tailgate. I don't want to force it in case something breaks. Can anyone help me?
  19. Rear Wheel Bearing

    Hi all, new here we have a 2007 Fusion Style 1.4 petrol and the rear wheel bearing went on my way home 2nite was just wondering how hard a task it is to replace. I'm pretty handy with a spanner and socket set but lack the knowledge really, but will tackle most things, i have stripped and re built the front suspension set up on our other car to replace the strut top bushes and didn't find that to hard. thanx in advance for any help received. ps can I follow this forum with my mobile app tapatalk?
  20. Currently trying to find a site that sells genuine focus st bumpers and skirts ect, not having much luck at all... Is there any good sites that i'm missing?