• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Search the Community

Showing results for tags '2008'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Ford Owners Club
    • Review your Ford
    • Discount Scheme
    • New Member Introductions
    • Was it you!? FOC Members Spotted!
    • General Ford Related Discussions
    • General Chat
    • Ford Guides
    • Show off your motor!
    • Car Insurance Discussions
  • Ford Models
    • Ford Fiesta Club
    • Ford Focus Club
    • Ford Mondeo / Vignale Club
    • Ford Mustang Club
    • Ford KA / StreetKA Club
    • Ford Kuga Club
    • Ford Edge Club
    • Ford B-Max Club
    • Ford C-Max Club
    • Ford S-Max Club
    • Ford Galaxy Club
    • Ford EcoSport Club
    • Ford Fusion Club
    • Ford Puma Club
    • Ford Escort Club
    • Ford Sierra Club
    • Classic Ford
    • Ford Transit Club
    • Ford Ranger Club
  • Buy & Sell
    • Club Cars For Sale
    • Ford Parts For Sale
    • Classifieds
    • General Items (Non Ford Related)
    • Wanted
    • eBay Finds
    • Buy & Sell Archive
  • Traders
    • Opie Oils
    • Mountune
    • Burton Power
    • Puma Speed
    • Revo
    • Visit Owners Club Insurance Page
    • Owners Club Finance
    • Advertise Here
    • Evans Halshaw ST-3 TDCI Deal
  • Ford Modifications and Projects
    • mountune Discussions
    • Photoshopped Ford Photos
    • Ford Project and Build Threads
    • Ford Modification Discussions
  • General Forums
    • Ford Owners Club Meets & Regional Discussion
    • Maintenance / Servicing / MOT Discussions
    • Dealer Problems & Consumer Advice
    • Technical Knowledge
    • Wheels & Tyres
    • Detailing your Ford
    • Audio & Electronics
    • General Site Requests
    • Computing, Gaming and Geeky
    • Dash Cam Videos
    • Ford Motorsport
  • Back Office
  • Ford How-To Guides

Categories

  • Ford Reviews
  • General Ford Guides - Modern Fords
  • Ford Fiesta Guides
  • Ford Buyers Guides
  • Ford Focus Guides
  • Ford Fusion Guides
  • Ford C-Max Guides
  • Ford S-Max Guides
  • Ford Ka Guides
  • Ford Mondeo Guides
  • Ford Kuga Guides
  • Ford Galaxy Guides
  • Ford Puma Guides
  • Ford Escort Guides

Calendars

  • Community Calendar

Categories

  • Articles

Found 27 results

  1. Hi guys (and gals), Got a problem with my 2008 Ford Focus mk2.5, the outside/ambient temperature sensor isn't giving a reading and the red snowflake is permanently on the dash. I would usually just swap the sensor out for a new one (which I still may). But I know that usually when the sensor fails, it gives a stupid reading instead of just nothing. Is there a fuse for the ABT that I can check? Or anything else obvious before I swap the sensor? Thanks in advance! P.S how can I see photos in other posts? It just comes up 'photobucket p500' in the photo window?
  2. Im currently changing all the standard green illuminations in my fiesta to blue.. heated screen buttons, boot button, window buttons all hone blue so far and now im at the headlight switch. I have found one thats been pre-made already on ebay that is for a mondeo mk3.. exactly the same but can anyone tell me if the mondeo mk3 switch would have the same plug on the back as my fiesta? Might sound like a really stupid question but i thought itd be worth a go if it does then ill buy that instead of fiddling with leds myself. Or, does anyone know anyone that can help me with changing led colours?
  3. HI, my name is Del. I have a 2010 Kuga 2l Tiatnium tdci 4x4. Love this but need something bigger for work. Was thinking a S-Max 2.5T 06/07 for about 3 to 4 grand. Looking at the Mondeo, it comes with many extra features, eg. Keyless Entry and Lane Departure Warning. My thoughts are....... from a lucky position of having a few friends who are dismantlers and purchase crashed cars as donor cars.......... What could it take from other Fords to upgrade and 06/08 S-Max A few things I`ve thought of.... Keyless Entry Start Button Lane Departure Warning Front Full Electric / Full Leather / Heated and cooled Seats Convers+ updrage Some feed back would be so cool......thanks
  4. Ford Fiesta MK6 - Coolent

    Hi all, New to the forum as i noticed something on my car that I didnt think was normal. I have a MK6 fiesta 2008 (last year of this model) its done 23000 miles. I thought the exhaust had a bit too much white smoke the other day so I had bonnett up checked everything. As the bonnet was up i stuck my foot through door and revved the car up. I noticed that the coolent would splash up everytime i revved it. Its not leaking and the temp gauge is fine the hoses get hot from the radiator and theres no gunk in the oil cap. It just seems not normal. Is there air getting in somewere? Should i be worried? Its not leaking or anything you can just see it splash up in the coolent tank. does anybody elses do this when the engine is warm? The only symptom the car gets is juddering when setting off when engine is cold. only last about 10 seconds then its fine. Thanks
  5. My new Focus

    Hi guys and gals, Below are some photos of my new Focus, always wanted one and now I have one. There's also a photo of the Red LED's I've put in footwell and front roof light (map light??). I'm not a mechanic, but i'll give most things a go. (Currently modding a Ford Puma into a road rally car with a mate (i'm the nav), who's a mechanic, so am learning a lot there) Can't quite see but I've vinyl wrapped some trim as well, not much though, just the steering wheel and silver trim around gearstick. It's a solid red colour and i'm not sure. Ordered in some Red Carbon Fibre vinyl to try. Anybody wrapped trim in a red colour and got some photos?? Got a couple of questions aswell which I can't seem to find the answer for when using search or googling it. Firstly the red footwell lights just use the standard mount and bulb holders with LED bulbs in at the moment. Looking to fit an LED strip instead as it's brighter (or move the holder to a more central position and see how it looks) and am wandering if the wiring for the standard footwell lighting is sufficient enough to use for say a 15 - 30cm LED strip, or even if the wiring is even suitable to be soldered to an LED strip. Not keen on taking too much trim out and hard wiring things in to the fuse box, or door lights etc only 3 days into ownership. Secondly also looking to colour or hydrodip the front grill, anybody got any experience, or have done this and have a photo?? Just thinking it'd be a shame to add all this colour and light inside for none of it too stem to the outside. Any other simple mods, hacks, ideas, links, guides, tips or hints greatly appreciated. Thanks in advance for replying!
  6. st220 brakes

    ok, just a follow up to a previous post, will the st220 carriers with discs & calipers bolt straight on to my 2008 facelift model without upsetting balance etc
  7. Hello there fellow Ford owners. apologies first off, if this question has been answered a million times on here, please put me in the right direction and mods feel free to close the thread off. Ok, so I would like to know f I can update my Convers+ on my 2008 Mondeo TitX. I gather it's using the first build of software. Can I upgrade it for little tweaks like the parking sensors, bring up on the screen, gear change notification etc. Is this sort of thing possible? many thanks folks, any help appreciated.
  8. Hi, I bought a second hand Ford Fiesta Zetec Climate 2008 last week with only 43,000 miles on the clock. Immaculate inside and out, one previous owner. I collected it on Monday and whilst out driving it started revving really badly, very high, smoking and I had to pull over. It seemed to right itself and I thought it was just me and the new car but today while I was on the main road it did it again and went crazy. Thankfully I managed to get across three lanes and parked on a pavement before it stopped moving entirely. It won't move forward, only revs and smoke accompanies it. It is under warranty but would anybody know what the issue is? Scared the life out of me. Thanks in advance.
  9. Auto Open/Close Windows

    Just bought a used focus a few days ago and i noticed the driver side window opens automatically but does not close also, the passenger window also neither auto opens or closes which is quite annoying, i also cant use the key for this. Just wanted to double check that this isnt something wrong with the car. I tried a few of the window reset tutorials but they didnt work and i also wasnt sure if this was for my vehicle model. i have a Focus 1.6 tdci 2008 mk2 facelift i hope this isnt something that isnt available.
  10. Hi everyone looking for some help, i have diagnosed a problem to the rear of my instrument cluster,(ford focus 2008 zetec 1,8). The car had been playing up with all sorts of odd things being said on the dash, so i took the the option of giving the instrument circuit board a clean to see if this fixed it(it did not) but what i did find was the fault! which is the grey wire block connector on the back of the cluster does not engage properly when the lock is on causing the dash to think things are wrong with the car that are not, i found if i squeeze the grey block into the cluster the all faults go away and dash is fine,just wondered if anyone has experienced this and knew the best way to fix it, its so annoying knowing the fault but not knowing what to do to fix it, thank for any help
  11. Hi all, First post, sorry if this is in the wrong place. I've just bought a Fiesta ST MK6 08 plate with the Sony 2nd Gen CD player http://i372.photobucket.com/albums/oo165/fordfiestast_co_uk/Album%20Four/f2efc84f.jpg I want to switch out the CD player for one with a USB plugin, but also want to make sure the steering wheel controls still work, I'm pretty sure I need a double din, something like this http://www.caraudiocentre.co.uk/product_m-jvc-kw-r510_p-32186.htm I've been into my local Halfords and they needed me to confirm if some kind of connector was bowed or unbowed?! Can anyone let me know if the CD player I linked will work and what kind of connector cables/other parts I will need? Also if I need a bowed or unbowed connector of some sort? Thanks Chris
  12. Hi Guys and Gals, I have owned my 2006 1.4 Diesel Fiesta for just shy of a year now. I commute almost 100 miles a day in it on the motorway, and average around the 60MPG mark (I reset the counter on the first of the month). Over the last few months I have noticed the average MPG start to slip. First to the mid 50s then the mid 40s. Something is obviously not right. This morning on my way to work, the average MPG dropped dramatically (by about 10MPG) when going up a steep hill on the A31. Once the road leveled out the MPG continued to fall down to around 33MPG. Eventually it started to climb again ending around 38. Driving home from work today, the counter started accelerating, 40, 45, 50, 55 by the time I got back it was about 58. Any idea what would cause such a rapid change in MPG? As I mentioned, I reset the counter once a month (on the first) to keep track of my fuel usage over the month. So the average was being taken over the last 1,400 miles. Full disclosure, the turbo has been whining for about 9 months now, think its finally giving out? Thanks for any help.
  13. Hello all. I've just purchased an 2008 Ford Fusion 1.6 TDCI. I wouldn't mind having a go at re-calibrating the ECU to get better driveability fuel economy etc. As it happens I am an engineer and for the past 2 1/2 years I have been recalibrating the ECU of a 1.6 TCDI (DV6) engine for emissions with an adaptered manufacturer ECU. (Unfortunately I have no idea how to do a normal production ECU) Maybe I will just do an EGR blank instead! -Though I'm not sure wheather to have a hole in the plate or not on my model? Unless of course I can find an easy way just to remap it? Or borrow an ECU from work? Thoughts? Thanks
  14. I recently purchased a 57 plate (Jan 08 build) dealer part ex Ka, and apart from a few bulbs and the standard Ka rust beginning in places it appeared to be a good car. Just over 60k miles and a decent bit of service history to go with it, although I did my own oil/filter/air filter change as soon as I got it. After a week or two I started to notice it was losing a bit of water, not massive but noticeable when looking in the water top up tank. I kept an eye on it and topped it up when necessary. Then this past weekend I noticed the fan has started kicking in, and the car was running relatively hot (but I never got a temp warning light) so I decided to do a bit of troubleshooting. I started with the thermostat, and noticed that the entire thermostat housing was leaking quite visibly, so I removed that, cleaned the area and put on a whole new unit. While I took that off I noticed the thing was coated on the inside with what looks to be radweld, making me worry a little and it would explain why this isssue appears to be getting gradually worse if someone chucked a load in before they part ex'd it in. Long story short after all that, the fan's still kicking in, the water pump seems to be okay as when I removed all the hoses to get to the thermostat housing and tested her she spurted everywhere. The only things I can think now are radiator issues, an airblock, or worst case a headgasket. Now the car does put out a little water out the back, not a massive amount, no oil in the water or water in the oil (no gunk) and power seems fine. I'm a bit stumped as to my next step and any help would be appreciated, thanks in advance.
  15. Hi everyone, I have a 2008 Fiesta Zetec Blue I have just noticed a rattlong noise that seems to be coming from around the rear wheel on the passenger side while I am driving. It sounds to me like its metalic. I am going to get it seen to this weekend but i'd like to find out weather it is a common problem or if anybody else has had the same issue? Does anyone know what they think it could be? Any suggestions would be great! Thanks
  16. My Fiesta

    From the album Fiesta Zetec Climate MK6.5

    © Mikesin

  17. Fiestaaaaaa

    From the album Meet Aoife

  18. Ford Fiesta Zetec Blue Mk 6.5

    From the album Fiesta Zetec 2008

  19. Ford Fiesta Zetec Blue Mk 6.5

    From the album Fiesta Zetec 2008

  20. Hi, I've had my second hand Focus for a few months and a week or so ago the remote key fob stopped unlocking the car properly. I assumed it was the battery, so after waiting for an eBay replacement to arrive I opened the key, put the battery in and gave it a test, nothing. After a spot of googling I found out about the reprogramming mode done via the ignition, I did it and pressed the lock button after the beep, and nothing. I've seen conflicting literature regarding reprogramming the key and if a second remote key (which I do not have) is involved, my own manual doesn't seem too clear on it and numerous forum posts have not helped either. I don't have a multimeter, so I'm unable to tell if the key is completely broken and needs replacing or if it's working and it's somehow the car that's failing to receive the key's signal. So, first question, is there any way I can be sure which is at fault, the key or the car? Second question, assuming the key is in need of replacing, what is the actual procedure? It seems I need a new blank remote key (eBay I'm guessing), that may or may not need exclusive reprogramming by Ford. Many thanks for any help.
  21. Hi, I'm hoping someone can give me a bit of advice regarding my Fiesta ST Mk6. I've had the car for a few months and have recently noticed that it sometimes makes a whining noise after being driven hard. It seems to only make the noise at low revs and makes the noise both when being reved and when its under power. The car has only got 31k on the clock and I'm always careful to wait until the car has got to full temperature before driving it hard. If driven sensibly there's no hint of the noise. I've attached a link to a video i've taken so you can hear what it sounds like. If anyone has got any suggestions or advise that would be great. http://youtu.be/YP8vfhVyfME Alex
  22. Hi everyone! New to the Ford scene! Just picked up my second car after having a corsa c for a year! It's a Focus Mk2.5 2008 1.8Tdci Titanium.. It also has a front splitter that has slits near the wheels and sideskirts.. Not seen many models with those already on them while I was looking.. Can happily say I love the car after contemplating whether to get one the following Golf/A3/Astra. Not done much to the car yet apart from - Yellow Interior Lights - Yellow LED Sidelights - Xenon Fog Lights - Front Bonnet Trim Gloss Wrapped - Rear Boot Trim Gloss Wrapped Plans to do: - A Big Clean (hopefully soon :D) - Gloss wrap the bottom grill - Gloss Black or Gunmetal Grey ST Alloys - Probably a 35/40mm drop (wanting to keep the car subtle ) - A Remap (bit unsure whether its worth it :() - 6k HID Kit - Discrete subwoofer fitting Anyway, thats me done! Here's some photos
  23. Good Morning Everyone, I own a ford focus titanium 1.6tdci 58 reg. It has done 91k miles. The car has been running fine until recently... If i accelerated off the line in gear one with roughly 25-30k revs the engine would cut out. I.e. putting my foot on the accelerator would do nothing. A sudden loss of power with no engine warning lights coming on. If i switched off the engine and immediately turned it back on the car would start again. I replaced the fuel filter and air inlet filter as good measure. The problem was then eradicated. It no longer loses power at lower speeds. I also took it for a service as they have the ability to flush through the system. The oil was also replaced with Castrol oil and engine coolant topped up. However, 2 days ago whilst driving on the m6 in the 3rd lane doing around 70mph the same thing happened and i had to drive across to the hard shoulder with what momentum the car had left. I then started the car again and it worked and i drove at 60 all the way home From a visual inspection of the car i've noticed #2 injector has caused the inlet manifold around it to melt slightly. I believe the HP pipe was causing the leak, i have torqued the nut and no more leaks. I'm averaging around 58mpg which leads me to believe that this isn't causing any problems. From revving the car i can see no signs of any leaks or any abnormalities. I have also used the ford diagnostic tool and my car has no fault codes The turbo seems to be working fine and kicks in as it should. I'm not entirely sure what the problem could be so i thought id post here to see if anyone else has had this issue before i start taking off components. I.e. wheres the best place to start If any more information would be helpful please ask. Many Thanks in advance.
  24. Hi, I recently 'upgraded' our trusty year 2000 Focus Estate 1.6 Auto for a newer model .. a 58 plate 1.6 Petrol Auto Estate (32K miles). Whilst the new car is indeed a more pleasurable drive, I do find it less 'sporty' than the old one .. but as I use it for running about town, I'm happy to accept the improved fuel economy :) over acceleration. The only niggle I have is that the car 'vibrates' when idling/stationary (both in neutral and in drive). I can feel this through the steering wheel, which is annoying .. and can 'see' the vibration in the side mirror(s). Problem is that, as far as I can tell, it is not possible to adjust the idle speed ... everything is now in the hands of the engine management system (EMS) .. but I'm convinced just a small increase would improve matters, as when I switch on the airco, the expected increase in RPM (though hardly measurable on the rev counter) seems to the reduce the vibration problem (though this may be just coincidence). I believe the idle speed is set by the EMS based on inputs from various sensors. Does anyone know which sensors exactly ? .. so I can check they are okay .. or have any other ideas of things I can check which may be causing the idle speed to be slightly too low ? I've had the plugs out .. which look okay (and all 4 look similar). The car starts and drives fine. I've checked fault codes with my basic OBDII reader and none come up. TIA
  25. Hey! A couple days ago I got a Fiesta Zetec '08 Special Blue Edition, and I can honestly say I love it, absolutely fantastic car! So many nice little features that you wouldn't even think about when purchasing it but genuinely do make the car that much more enjoyable to be in. Small side note, am I right in saying this is a mk6.5 Fiesta? (58 plate but not new style) So, onto the topic in question; the headunit. About a month ago I bought an Alpine CDE-123R headunit which I plan on fitting into the car. The car currently has the stock Sony headunit fitted and I want to know what kind of cables/adapters/fascia I need to acquire to fit my Alpine headunit. The current headunit in the car... Note; not my picture. I want to be able to connect my iPhone 5 via USB and use it to play music, not interested in the whole bluetooth/handsfree in car calls. I already know, or believe I need to get a set of removal key tools. http://www.ebay.co.uk/itm/FORD-Focus-C-Max-Mondeo-Fiesta-CD-Radio-Stereo-Removal-Keys-Pins-6000-6006-CDC-/250904481702?pt=UK_In_Car_Technology&hash=item3a6b128fa6 However after this stage I'm kind of stuck, well I reckon I could work it out as I go along but I have no clue what other parts I will need. I think I'm going to need some form of adapter as the Alpine headunit has a different shaped cable block at the back. Also will I be able to use volume changer on the steering wheel? Any help would be very much appreciated, and I once I have it all figured out I do plan on making a guide for this model Fiesta as there doesn't seem to be any out there (well none that I could find).