• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Search the Community

Showing results for tags 'Steering'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Ford Owners Club
    • Review your Ford
    • Discount Scheme
    • New Member Introductions
    • Was it you!? FOC Members Spotted!
    • General Ford Related Discussions
    • General Chat
    • Ford Guides
    • Show off your motor!
    • Car Insurance Discussions
  • Ford Models
    • Ford Fiesta Club
    • Ford Focus Club
    • Ford Mondeo / Vignale Club
    • Ford Mustang Club
    • Ford KA / StreetKA Club
    • Ford Kuga Club
    • Ford Edge Club
    • Ford B-Max Club
    • Ford C-Max Club
    • Ford S-Max Club
    • Ford Galaxy Club
    • Ford EcoSport Club
    • Ford Fusion Club
    • Ford Puma Club
    • Ford Escort Club
    • Ford Sierra Club
    • Classic Ford
    • Ford Transit Club
    • Ford Ranger Club
  • Buy & Sell
    • Club Cars For Sale
    • Ford Parts For Sale
    • Classifieds
    • General Items (Non Ford Related)
    • Wanted
    • eBay Finds
    • Buy & Sell Archive
  • Traders
    • Opie Oils
    • Mountune
    • Burton Power
    • Puma Speed
    • Revo
    • Visit Owners Club Insurance Page
    • Owners Club Finance
    • Advertise Here
    • Evans Halshaw ST-3 TDCI Deal
  • Ford Modifications and Projects
    • mountune Discussions
    • Photoshopped Ford Photos
    • Ford Project and Build Threads
    • Ford Modification Discussions
  • General Forums
    • Ford Owners Club Meets & Regional Discussion
    • Maintenance / Servicing / MOT Discussions
    • Dealer Problems & Consumer Advice
    • Technical Knowledge
    • Wheels & Tyres
    • Detailing your Ford
    • Audio & Electronics
    • General Site Requests
    • Computing, Gaming and Geeky
    • Dash Cam Videos
    • Ford Motorsport
  • Back Office
  • Ford How-To Guides

Categories

  • Ford Reviews
  • General Ford Guides - Modern Fords
  • Ford Fiesta Guides
  • Ford Buyers Guides
  • Ford Focus Guides
  • Ford Fusion Guides
  • Ford C-Max Guides
  • Ford S-Max Guides
  • Ford Ka Guides
  • Ford Mondeo Guides
  • Ford Kuga Guides
  • Ford Galaxy Guides
  • Ford Puma Guides
  • Ford Escort Guides

Calendars

  • Community Calendar

Categories

  • Articles

Found 56 results

  1. I was wondering if it would be possible to retrofit heated steering wheel to a MK7 Fiesta because I've looked and heated steering wheel covers don't seem to be that great from reviews.
  2. Krisdadude online about 1 hour ago · #1 Steering Wheel Wobble (NOT WHEELS) I have had my 2010 focus 1.8 zetec s 3 door for 4 months. Since Day one the steering wheel has a wobble from 60mph+ most notible from 60-70 and when accelerating. It seems identical to a wheel balance issue but is not. FYI: I have had the tyres balanced 20 times didnt help. New wheels and tyres both balanced numerous times, swapped front to backs vice versa. Still wobbling. New drive shafts left and right. Since the new drive shafts the vibration has increased slightly and i seem to have more vibration on acceleration up to 60mph then steering wheel wobble, it also can be intermittent, not sure whether it is caused by road up or downhill. Dont know but I could be feeling accelerator vibration also but could be just clutching at straws. All but one mechanic I speak to doesnt have any ideas, spoken to approx 12 different mechanics, the one who had ideas just named a big list to go through. Any ideas would be appreciated.
  3. Heavy steering

    Hello one and all. I am aware that heavy steering is a known problem on mk1 ka, and that the steering column UJ can become very stiff causing problems. Some variants seem to have a replaceable universal joint and others don't. Is it possible to tell by model variant or VIN number which type of column I have on my ka? Mk1 Ka style climate 1.3 duratec 2007. Thank you.
  4. Ongoing steering issue

    Hi everyone I am hoping that someone out there may be able to shed a little light on a problem i am having with the steering on my mk6 fiesta zetec. It is on an 06 plate and i purchased it about 3 months ago. Firstly a little background that i feel may be relevant.... The garage that sold it to me told me it was a great runner with no faults and a full service history. This wasn't exactly true there was a grumble from the engine on the test drive and the FSH turned out to be a book of service stamps and the online MOT certificates (no originals ones except for the last 2). Despite this i bought the car and took it straight to my mechanic who told me there was some niggles that needed addressing under warranty. This included a snapped front spring (the bare metal where it had broken had rusted so it was definitely an old problem), a noise from the bearing on the rear drivers side and what they thought was a leaking power steering pump. I took it back and they remedied these problems. They said at the time that the power steering pump wasn't broke but the fluid was from a previous repair they had done, that they had simply failed to clean A month or so out of warranty i got in the car and started to drive away and noticed the steering felt very loose and light, i quickly took the car to my mechanic who after looking at it decided the power steering pump was broken (it was making a noise when turning the steering wheel). He replaced it with a brand new one and new belt but it had a very loud whining sound that my mechanic said was air in the system and if it hadn't cleared in 48 hours to bring it back. I didn't clear and i brought it back in. He checked the old pump said there was actually nothing noticeably wrong with it and put it back in but replaced the power steering fluid with some very high quality fluid, this seemed to fix the issue. By the way my mechanic is an old friend so i trust his work. Over the next fortnight or so i have noticed the steering was very loose and light again, my mechanic assures me he can not see anything noticeably wrong. He says the pump is fine, tie rods are good and steering rack was fine with no play at all. If i turn the wheel and look at the wheels they move in time as in there is no play/ delay between adjusting the steering wheels and the actual wheels moving. It is almost as if the steering ratio has changed. Also the steering wheel seems to be affected by every bump, hole and pebble i drive over, twitching significantly when i do. Finally if i turn the steering wheel to full lock it makes a low whining noise. Can anybody shed any light on this i am at a loss. I have googled this issue extensively and can't seem to get to the bottom of it. Thanks in advance
  5. Hi All, My 2005 zetec fiesta recently had an MOT, failed on broken number plate (not a problem). As part of the test they shake the car like mad, it seemed pretty violent which concerned me, prior to the MOT I had no problems with the car at all. As soon as I pull out of the centre, turning left I can feel a vibration almost rubbing. This is most apparent as slow speeds and doesnt appear turning right. 1.Tyres are fine, full of air. 2. I got them to take a look at the car on the ramp- spring/suspension are fine from what I can see no obvious damage or reason for the rubbing/vibration. 3. From my research could it be: a bearing issue? a steering pump faulting? 4. There was no issue before the MOT but the issue started immediately after, what could this be? Appreciate your help guys, anyone else experience this or an idea of what it could be?
  6. Morning, This one is a fix I wasn't planning on having to make. My son has got a penny into the casing of the steering wheel so now when I corner there is a rattle almost as annoying as the child that caused it to happen. I've seen some guides on removing steering wheel for airbag issues and most quote disconnecting battery and leaving for 20 mins before disconnecting airbag connections. Do I need to do this though? I'm not going to be pulling any wires away, I just want to free the cover on the front of the wheel so that I can see inside and recover the penny. Thanks
  7. Steering wheel adjustment

    I can't adjust my steering wheel on my Fiesta 2010 model MK7 I believe(not the face lift though) I don't have a lever although in the manual it specifies I do. i have a bolt here which appears to be on a runner, although I'm not confident. I've uploaded a picture (not really clear either I know) can somebody help me. thanks in advance.
  8. Multiple symptoms

    Hi I've got a 2007 KA studio with 86,000 miles on it. I've owned it from new so I know it's full history. Suddenly in the last day I have noticed a rattling sound coming from the engine. The pitch of the rattling sound increases with the speed of the engine so at first I suspected at clutch / pilot bearing type problem. However, when I turn the steering wheel there is a loud howling sound as well. This sound is quite noticeable when I turn the steering wheel quickly from full lock to full lock. So next I suspected the steering pump was on the way out? There is also a red fluid leaking from the front near side of the engine compartment (just forward of the prop shaft). I assume this red fluid is power steering fluid? Given that the steering pump is located in offside of the engine compartment and the fluid is leaking from the nearside I'm a little confused as to what is going on? Also there is a black sooty deposit round the filler cap of the power steering reservoir, I know that wasn't there a couple of months ago when I did a service on the car. Performance wise the steering seems to work ok and there is not change in braking (it doesn't pull to one side when braking). I have checked the fluid level in the power steering reservoir and it has fluid in it. Anyone got any ideas as to what might be going on here? Have I got a steering ram on the near side leaking and a steering pump failing at the same time? Seems a bit of a coincidence to me? Thanks in advance dvd
  9. Hi all, As of yesterday the steering in my MK1 Focus seems to have got a a bit heavier. I'm not having to put much effort into turning, pretty much the same as usual but there's definitely a weight on it. Also, the pedals seem to feel heavy as well. Not sure if that's the correct way of mentioning it but they seem harder than usual. I checked my power steering fluid level, that's right at the top. The car still drives in a straight line and breaks in a straight line. Any ideas? Thanks in advance!
  10. I have a 07 focus ghia, and my mechanic has told me the bushes have gone on the steering rack, does anyone know were i can get these they seem almost impossible to find have found some in the US just seeing if anyone else has had a similar problem
  11. Hi all, Just had the brake pads and brake disks replaced on my ford focus 1.6 2009 mk2. Driving home from the service centre I've noticed that when the steering wheel is straight the car goes slightly to the right! So i have to have the steering wheel going slightly to the right to make sure the car is straight. now i will definitely take it back to the garage Monday however any ideas what this may be? Do you think its linked to the fact ive just had my brakes done, the steering was fine before having that done. any help is appreciated
  12. Radio buttons not working!!

    So I have an 07 fiesta... I was on my way home from work and pressed the mute button on the radio... then used the controls on the steering column to get it off mute by pressing the up volume button (I've done this before with no issue) next thing I know the volume has gone all the way up to 20!!! I tried turning it down with the steering controls and on the actual dial thing and nothing worked! So I turned it off (the only thing that worked)... I got home and check all the other buttons and NONE of them work... so now my radio is stuck ridiculously loud with no way to turn it down! Help?!
  13. Hey, not sure if this is the right forum I've just signed up to see if any of you guys can help. i have a Fiesta zetec s TDI 1.6 2006. I've only had it a few months and have had nothing but trouble with it tbh. The car pulls left intermittently it's just like something clicks or gets stuck which makes it pull then after a minute it'll be fine and will drive straight. Sometimes it's worse than others. Going over every little dent or anything in the road causes the steering wheel to go mental. also going at around 60mph the steering wheel shakes pretty violently. its just passed it's MOT, had tracking done and my mechanic can't find anything lose anywhere, said it could be the steering column but it might not be! Unsure of what to do. i have just taken out rac cover where they pay for repairs, just wondering if they would repair something like this if I said I couldnt drive it! Save a bit of money!
  14. steering wheel and airbag

    so as most of you know i changed my steering wheel since then its been bugging that the airbag light is on is there any way to like create a circuit so its not just staying on and that it still works? or am i better off just putting black electric tape round the it like the majority of the people Thanks in advance :)
  15. Hi all, My other half has a 1.4 Fiesta Zetec '09, and it's recently developed a squeak on the O/S whilst steering. At first I would have said it was the CV joint, however as the squeak has started getting worse, it's almost certainly not the CV joint, as it only "appears" when the steering turns slightly left - when the steering is dead straight, if you turn the steering wheel to the left to what would be the 11 o'clock position. It's probably not even that far - maybe only 20 degrees or so. It only happens when turning left whilst travelling under 40mph. We had a motorway run out yesterday and couldn't hear it at 50+. I've done a bit of reading and generally the brakes are to blame, but I've also read that the PAS pump could also be the culprit. She's wanting to take it to the garage, but I'd rather gather a bit of background on the symptoms and take a look myself before potentially getting shafted by a garage. Thanks for your time folks
  16. Recently been having a squeal/grinding when reversing with full left lock, believe to be a result of the broken suspension/steering shown in the picture below. What part is this, how easy is it to replace, and what is the likely cost if I take it to a garage? How dangerous is it to drive the car while it's broken? Hope to get it fixed on Monday, and can avoid using it until then, but useful to know its function.
  17. I recently purchased a new stereo for my wife for her MK1 Focus. I purchased both the Autoleads PC99-X07 (Harness and Steering Stalk Control Adaptor), as well as PC99-SON (Sony patch lead) and installed with no problems except that I have no control from the standard focus stalk controller. I have double checked all of my connections and everything is where they are supposed to be, I know that there are some settings on the stereo for steering controls but I am unsure if I have to set this and whether the focus would actually recognise any settings, I did try setting the controls to auto but it just shut down the head unit and I had to reset it. If anyone else has had similar issues or can advise, that would be great. Many thanks
  18. Hi Everyone, This is my first post on here but in need of some serious advice I bought my second ford focus recently a Focus Zetec Climate 1.6 2005. when I do between say 60mph and 80mph the steering wheel begins to vibrate/shake. and when day to day driving its almost as if there's grinding/ rubbing noise on the passengers side front tyre, it sounds as if im running on the alloy where the wheel is really flat but I have put air in it. Also when I go over bumps that specific will knocks loudly like the bolts are lose but ive also checked this. I am by far no mechanic but really enjoy cars and can do the easier stuff but just give things ago. this specific tyre was really hard to put back onto the hub when taken off, so I swapped the two fronts but the other wheel was also having trouble getting onto the hub, could it be the hub is the wrong size and causing this? I guess what im asking is does anyone know what may be causing this and if so how can I check it? Thanks in advance!
  19. Hi, This problem may or may not have been triggered by hitting a pothole. I've had two different garages look at my car but other than a worn bush they could find nothing wrong. The issue I have is only when turning left. At about half-lock there is a resistance/"judder" felt through the steering wheel and a noise also from the steering wheel. It is worse the more load is being put through the steering i.e. taking a 90deg left hander at pace. Some times it feels as if the left wheel doesn't want to change direction. I've trawled the net for similar issues but can;t find anyone who has the same problems. Any help would be greatly appreciated Cheers Mark
  20. steering column movement

    Hi i have recently purchased a mk4 fiesta race car and the steering column has slight movement up and down, does anyone know what might be the problem?
  21. Ok so I bought this car earlier in the year. Has been fantastic for my family especially getting to hospital appointments with my daughter (she has a rare condition) My car, a 53 plate fiesta finesse was due mot 22nd Dec so I took it early. Arnold Clark found it needed a middle section of exhaust and three brake pipes. Got these all replaced at small garage and car was taken back for retest and passed! Got car home and since driver has brought it back it's had nothing but problems. This morning it was starting but unless reved it would cut out while idle. As the day went on it has stalled at every junction, roundabout and when lowering speed. The steering lock (yes the steering completely locks!) has completely locked after stalling a number of times (I ended up on pavement at one point as I was turning into the road!) AC want nothing to do with it as he only looked at car for mot and didn't touch anything. Another garage replaced fuel pump and I'm now stalling at a couple junctions but steering wheel still locking. Have spent 400 so far and at my wits end!! Garage noted rev counter shoots up and down too. All before Xmas too! Terrified to drive it and can't put kids in it. The car has v clean engine, and only 67000 miles so shouldn't be doing all this surely?!!
  22. Hi everyone, I'm really frustrated that my Ford Focus has developed a clunking noise. I firstly noticed a slight clunk when releasing the clutch pedal (after the biting point) and sometimes when i press it down. But yesterday it also happened when I was applying the breaks, when coming to a full stop it, it happened just before I stopped or halfway. And the break clunk sounds like its coming from the right wheel side but it hasn't happened today Finally I also get a clunk when doing a 3 point turn, again its a single clunk but not on full lock, it happens before that and sometimes when turning either side. These clunks/knocks are random and hard to recreate. The thing that annoys me is that they appeared after I had a clutch and slave cylinder change last week , brought it back to them and they checked for play in the wheels on the ramp and other noise but couldn't recreate the noise. Just blamed it on a loose exhaust mount/heat-shields. First I thought maybe they didn't change the slave cylinder, which would explain the clutch clunk noise but now I'm not sure. Any help would be greatly appreciated :) Car is Ford Focus (2006), with 100K+ on the clock
  23. Hey guys, I've got a 53 TDDi and after it sitting around for a week, all of a sudden I've started getting a clunking noise while turning the steering wheel stood still. Driving it seems to be OK the majority of the time, every now and then it happens. Found a video on youtube which looks to be the issue I'm having. They say it was the front springs, is there any way I can double check the springs before buying new ones? Replaced my steering rack a little while ago (roughly 2/3 thousand miles ago) so thinking it may possibly be that. Heres the link: Any help would be much appreciated.
  24. Hi New to this forum, so apologies if I make any errors. I have a 2002 Galaxy petrol automatic 2.8 litre, 42,000 miles, which has developed a juddering noise when turning to the left at 20mph and above. Prior to this happening, I had a new passenger side shaft and coupling fitted during PDI, and since have had a wheel bearing fitted on the passenger ( left) side to try to get rid of a rumbling noise, which worked. Within 50 miles of it leaving the garage, it developed a juddering when the wheel was turned to the left. We were on our way to France ( which is where we now are) and we had no problems driving down, except that I took things very slowly when turning left. We have placed the car in our local garage, who were convinced that the noise was from the replacement shaft on the passenger side ( it turns out that our good old UK dealer who we bought from fitted a recon shaft which was worn) This has been replaced, but the juddering is still there. I think that the mechanic is a bit lost what to do next ( plus translation into French is not easy). If anyone has had a similar problem, I would really appreciate some guidance and advice, as I am reluctant to drive back to the UK until it is sorted.
  25. I have a 2002 KA and recently it has started to make a clunking noise when turning corners, usually sharper corners being taken at a slow speed. It seems to happen more when pulling up hill. Have had a google and not found anything. Seen a lot of posts with replies saying about the drive shaft but all looks fine and i am lead to think its not this as the noise is not there all the time. Is this a common problem? If anyone has any suggestions or advice I would be very grateful. Thanks in advance :)